Fiducial markups not showing in 4.11.0

image

Hi!

Sorry for stupid question. Fiducial markups I’ve created using slicer 4.8.1 don’t appear in the 3D window (appear fine on the other 3 windows) on slicer 4.11.0. Any idea where I did wrong?

Best regards
Hao

I could not reproduce the issue. Please try with the latest nightly build. If it still fails then please upload an example scene somewhere (dropbox, onedrive, etc.) and post the link here.

Hi!

Thanks for replying.

I have tried further versions of slicer. The fiducial markups show fine on (4.10.1) but only not on (4.11.0-2019-04-12).

Here are two movies showing 4.10.1 and 4.11.0. The fiducials were saved in slicer 4.8.1.

I’ve also figured out how to make it work in 4.11.0-2019-04-12. You need original data (CT), then add a few fiducials. Then open the previously saved fiducials, and it will work.

Best regards
Hao Li

Thanks for the videos. I was able to reproduce the issue and fix it. Tomorrow’s nightly build should work well.

Hi, the problem still occurs in 4.11.20210226 (Win10).
The mrml/mrb files build in 4.10.2 are incorrectly showed without markups-fiducials in slice windows. Pleas, keep back-compatibility =)
Best regards,
Radek

We always maintain backward compatibility with at least the previous major version (and as much as possible, with earlier versions, too).

The problem you encountered is due to that Slicer-4.10 did not take into account slice visibility attribute for markup nodes and Slicer-4.11 does (and by default slice visibility was turned off for markups).

As a workaround, you can right-click on eye icon of the markups node in Data module and check “2D visibility”, I’ve also submitted a fix that enables 2D visibility for markups by default when an old scene is loaded (it will be available in Slicer Preview Releases downloaded tomorrow or later).

Dear Mr. Lasso,

Thank you for your response, but my problem is probably different. I remember on your described solution, some fields in .fcsv were incorrectly read (older version read 1.00 as true, in 4.10.2 only 1 was accepted).

However, the actual problem is different. Markups module of 4.11 shows everything as showing. The warning is similar for both versions, which can be confusing. Fiducials in 3D view are shown, not in slices, and change properties affect only 3D. The only working way is manually adding the fiducial list to the scene, which leads to a built-up new DataNode.

Here are a screenshot and link to the example .mrb file.

https://owncloud.cesnet.cz/index.php/s/qCKvS4Yi0sAX1RE

This problem covers an extensive dataset of our research that prohibits using actual versions of Slicer.

Thank you for your time.

Best regards,

Radek Janca

As I wrote above, you can right-click on the eye icon of markups fiducial node in Data module and check “2D visibility” option to fix the loading from old scenes.

You can also use the latest Slicer Preview Release that automatically enables 2D visibility for markups fiducials when loaded from old scenes (I’ve just tested Slicer-4.13.0 2020-04-10 and it displays your Slicer-4.10.2 scene correctly).

Slicer-4.13 has lots of improvements in markups. I would recommend to have a look at markups curves, which you can use to display electrodes as lines instead of just point sets (but you can assign names to each control point of the curve as you can do for markups fiducials):

Oh, it is working, amazing!

Thank you a lot for your time, and I am sorry for my ignorance. It is a new feature for me.

Best wishes,

Radek Janca

1 Like