Fiducial visibility range in slice view

When I am in slice view, how close does a fiducial need to be in order to be visible?
Is there a way to control this and make more of the nearby fiducials visible?

If fiducial projection is disabled then you always see the fiducial on the current slice, i.e., within +/- slice spacing distance. You can adjust slice spacing manually if you want to show more fiducials.

I’m not sure I follow. Doesn’t changing the slice spacing mean that the fiducials don’t match the anatomy?

I meant changing the slice spacing in the slice viewer:

Got it. Thanks! (need 20 characters)

1 Like

@lassoan, this had been a confusion for us a while, and now I understand the issue. If the ‘interpolation’ option in the volume setting has been unset (no interpolation), this spacing has no effect. You can try with MRHead and set the slice spacing to 0.2mm and then see that for 4-5 slice increments no change in the slice is visible, even though the sliders shows move.

We do disable the interpolation quite a bit to be able to follow voxel boundaries in manual segmentations.

I think this needs to be somehow disabled if the interpolation option is not used.

What would need to be disabled?

Setting the slice spacing something different than the image spacing.

The slice offset slider certainly needs improvement. Most importantly, it needs a “snap to slice” mode (see for example discussion here How slice selection slider should work?), but it is a complex issue. For example, markups still need to be placed at arbitrary locations (not just at voxel centers), but then what would you display when the user wants to jump to a markup point location? A potential solution could be to add a “snap” button, which would jump to nearest slice and would probably override manual slice spacing. When slice position is set to a non-center voxel, or slice spacing is adjusted manually, or the slice view is rotated, then then “snap” mode could be automatically deactivated.

Disabling interpolation of grayscale images leads to many subtle problems. One of them is what you noted, but things even get worse when you have non-axis-aligned views, overlay model intersections, markups, etc. that I would not recommend anyone to use it.

Did you disable interpolation because you wanted to see voxel boundaries? For that, a proper solution would be to show a grid when you zoom in a lot - as it was done in Slicer-3.x. Unfortunately, this feature has not yet ported over to Slicer-4.x. It would not be hard to implement it, especially if you only need it for non-rotated views.

In your workflow, why did you adjusted the slice view spacing manually?