Fiducials Segments alignment in 4.11 using fiducial registration wizard

I am new to 3D slicer so sorry for most likely basic question. I am aligning a head CT with a target created from markups list with a post-procedure CT with the needle. When saving the scene I get the error: fcvs file format only stores control point coordinates and a limited set of display properties. After reopening the scene which was saved the most crucial part of the scene (aligned target with needle) is not displayed. Is it this related to the error? Or is it something else I do wrong? I am enclosing pictures
Thank you very much for your help

Can you describe what procedure you use to do the alignment? You should use a Transform to one of the datasets to bring them into registration and this would be saved in the scene and reloaded.

Hi Steve, I am using IGT-> fiducial registration wizard-> and then I am creating the new linear segment and then in Data I click on the transform to align models like in this youtube video

Hmm, that should create a transform that’s saved with the scene. I’m not a SlicerIGT user or developer so maybe someone else can comment on how to save the transform.

1 Like

This is a warning, it is not an error. FCSV format is the older format for the Markups and it doesn’t retain all the information (derivative measurements, color settings etc) that the newer JSON format does. The warning is there to remind people about that. But perhaps wording can be a bit better.

I am not entirely sure why you are not getting what you are expecting.

1 Like

As @pieper said, the Fiducial Registration Wizard stores the result in the transform node that you specify at “Registration result (From->To) transform”. That transform node is saved with the scene and should be reloaded. Sometimes what causes an issue is that “Auto update” remains checked. That is the default state of the Update button. In that case the registration is recomputed every time the input fiducial nodes change. If you have an issue saving/loading the fiducial nodes, then the computation may fail. Maybe try to uncheck “Auto update”.

1 Like