Generating surface area from a 3D region

Operating system: Windows 11
Slicer version: 5.6.1

Hi all!

I am currently working on a set of human crania, and I am trying to quantify the 3D surface area of the region in the closed curve. I see that it generates an area but I am assuming that is just the area of the closed circle. How could I go about getting the surface area of the whole region up to the F1 landmark?

It is worth noting that these images are derived from a 3D surface scanner as we don’t have access to a CT machine. I will say that I am primarily used to working with CT data, so some of this is different for me. I have tried to convert the model to a segment and then cut out the regions I am not interested in to obtain a surface area from the Segment Statistics section, but I have two concerns.

  1. The model fills in the voided regions (it is a 3/4 scan), and it becomes extremely low quality in comparison.
  2. Because the regions are filled in now, I am unsure if it calculates the entirety of what is left for the surface area.

Because I am only interested in that highly specific region is there an easier way you would suggest doing it?

Thank you!

Segmentation is for representing volumes (represented internally by labelmap images, closed surfaces, etc.). It seems that you want to analyze open surfaces, therefore segmentations are not relevant bánt for you.

Instead, you can colour out surface patches that you are interested in using Dynamic Modeler module and get the surface area in Modules module / Information section.

1 Like

This worked exactly as I needed it to. Thank you so much!

1 Like

Hey @lassoan I was hoping to ask you about some weird behavior with the Dynamic Modeler module. I have found a scan of an individual where I don’t get the expected result.

Here it is before cutting

Here it is after cutting

Here is a general mock-up scheme of how we are placing the CC edges. We are generating a segmentation to only use the planes, it has been turned off in the tree.

Do you know why the Dynamic Modeler would cut so far away from the demarcated area? That is the specified “inside” section being rendered there as well. So I initially thought it was an issue with the model. So I rescanned a smaller section today, but I had a similar issue with generating smaller pieces, albeit at least inside the circle. Just now, I tried to replicate the behavior again on the original and not the new scan, and it worked. This behavior seems strange to me as I was able to cut out about 20 regions so far without issue.

It is worth noting that two versions of the slicer are being used, 5.21 and 5.6.1, but I did have the issue across both versions.

I have included a google drive link here for replication:For slicer - Google Drive

Thanks ahead for any input you or others may have to offer!