GUI trouble at first installation - green stripes on the application screen

Excuse me , please help me from the installation trouble.
I’m sorry I can’t write English well

I installed 3D Slicer to Windows 64bit PC.
But when I started 3D Slicer , I get a lot of black and green lines in my application.
This is screenshot.

This is the log text of 3D Slicer.


[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Session start time …: 2020-12-04 10:39:43
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Slicer version …: 4.11.20200930 (revision 29402 / 002be18) win-amd64 - installed release
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Operating system …: Windows / Professional / (Build 19042, Code Page 65001) - 64-bit
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Memory …: 8070 MB physical, 9990 MB virtual
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - CPU …: GenuineIntel , 8 cores, 8 logical processors
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - VTK configuration …: OpenGL2 rendering, TBB threading
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Qt configuration …: version 5.15.1, with SSL, requested OpenGL 3.2 (compatibility profile)
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Developer mode enabled …: no
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Prefer executable CLI …: yes
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Application path …: C:/Users/GIROJ-Admin/AppData/Local/NA-MIC/Slicer 4.11.20200930/bin
[DEBUG][Qt] 04.12.2020 10:39:43 [] (unknown:0) - Additional module paths …: (none)
[DEBUG][Python] 04.12.2020 10:39:45 [Python] (C:\Users\GIROJ-Admin\AppData\Local\NA-MIC\Slicer 4.11.20200930\lib\Python\Lib\site-packages\pydicom\datadict.py:432) - Reversing DICOM dictionary so can look up tag from a keyword…
[DEBUG][Python] 04.12.2020 10:39:46 [Python] (C:\Users\GIROJ-Admin\AppData\Local\NA-MIC\Slicer 4.11.20200930\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: Annotations
[DEBUG][Python] 04.12.2020 10:39:46 [Python] (C:\Users\GIROJ-Admin\AppData\Local\NA-MIC\Slicer 4.11.20200930\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentEditor
[DEBUG][Python] 04.12.2020 10:39:46 [Python] (C:\Users\GIROJ-Admin\AppData\Local\NA-MIC\Slicer 4.11.20200930\lib\Slicer-4.11\qt-scripted-modules\SubjectHierarchyPlugins\AbstractScriptedSubjectHierarchyPlugin.py:36) - Scripted subject hierarchy plugin registered: SegmentStatistics
[DEBUG][Qt] 04.12.2020 10:39:47 [] (unknown:0) - Switch to module: “Welcome”


I will use 3D Slicer in my AI development, so I really want to resolve this trouble.
Please help me.

This is caused by a bug in your Intel Graphics driver. Upgrade your driver to the latest version to fix it.

If you are interested in more details, you can search for “green stripes” on this site.

Thank you very much!
I got latest graphics driver from Intel, and this trouble was resolved.

2 Likes

I have the same issue with my Dell Precision 7740 i9. My graphics driver of Intel us the latest. I still cannot solve the problem. I downloaded the driver from the Dell website and the driver is the newest one, which Dell recommends to my computer. I wonder what you did to solve the issue. Thanks.

It may take Dell a couple of months to update their driver database. In the meantime, you can install the driver yourself from the links provided here: https://community.intel.com/t5/Graphics/Request-for-details-on-Intel-HD-630-green-lines-in-OpenGL-apps/td-p/1202179

1 Like

I downloaded and installed the latest version (newer than what you suggested). It works now. Thank you very much. Yoichi

1 Like