How to cut multivolume dicom into single ones?

Operating system: Windows 10
Slicer version: 4.11
Expected behavior: I load multivolume (contrast enhaced dyn) dicom to make a subtraction.
Actual behavior: When the multivolume dicom is loaded, Slicer only shows the first frame (without contrast) and I can’t find how to even see what other frames look like not mention to make subtraction.
Can anyone help me?

A few things that would help to understand this problem:

  1. When you go to your DICOM browser → select “Advanced” → Examine, do you get a list of sequences that you can select? A screenshot would be helpful
  2. Try loading your study as a volume sequence (Application Settings → DICOM → Preferred multi-volume import format)
  3. You can also try dcm2niix, I remember it was being recommended around here for converting multiframe DICOM to nifti/nrrd and then loading that format
  4. If it’s possible, sharing a sample anonymized study with us would be helpful in troubleshooting

I would recommend to load 4D volumes as volume sequences as @JanWitowski described above and then use the toolbar to browse frames. You can display multiple timepoints of the same volume sequence by creating a new browser node in Sequences module.

You can find step-by-step instructions for computing motion-compensated subtraction for segmentation of small vessels in this segmentation recipe.

Note that you may also browse or access frames and perform operations on them using numpy as shown in examples in the script repository.