[Newbie] Struggling with DICOM, MultiVolume and Sequences

Hi,

I would like first to thank you for this great and powerful open-source software! In a world where every postprocessing tool can cost a kidney, it is a relief to see people who care about improving and sharing research.

I’m an absolute newbie in Slicer, and although I’m used to many programming tools, I’m pretty lost in what I’m trying to do.

My goal: postprocessing DCE-MRI acquisitions

My materials:

  • T1 mapping: 3 separate series with different flip angles
  • DCE: 1 series with different time frames
  • “late” DCE: 1 *separate" series corresponding to a late time frame of the DCE-MRI acquisition

My first problem: when using the T1 Mapping extension, I need an MRMLMultiVolume.

Regarding T1 Mapping, how can I “make” a MultiVolume from my separate series?
When I use the MultiVolume Importer, it only requires a folder. Even when I select a specific subfolder with the distinct three series, it does not produce a valid MRMLMultiVolume. The only thing that I succeeded in achieving was creating a sequence with three time points, but I can’t convert it to an MRMLMultiVolume.

When I try to post-process the DCE series, I have the same problem, as it does not produce a valid MultiVolume.

Some help?

Thanks! :slight_smile:

MultiVolumeImporter should only be used if your input is a set of non-DICOM volumes. If you have a DICOM series with DCE or T1 sequence, you should import it into Slicer DICOM database, and load from DICOM browser as a multivolume. Depending on how the data was collected, you may see a single series corresponding to DCE acquisition, or you may have one timepoint per series. It is best to toggle “Advanced” checkbox in the DICOM browser, try Examine, and see if a multivolume is parsed from your DICOM content.

image

Thank you !

I didn’t know that MultiVolume Importer was for non-DICOM files. Maybe I should convert to NIfTII first ?

In the DICOM Importer, I already tried to play the Advanced Options. However, my acquisitions are not recognized as MultiVolumes… That’s why I’m trying to find a work around :confused:

That’s indeed a problem. Unfortunately, with multivolumes, it is very hard to debug without having access to the data. Most likely, your data should be parsed using a heuristic that is not part of the multivolume plugin. It could also be that the dataset is incomplete (for example, if a single slice is missing in one of the timepoints, it will not be parsed). If you share a de-identified sample, I can try to investigate.

Alternatively, indeed you could try to convert every timepoint into a separate volume, but I admit I have not used that non-DICOM load functionality in a long time.

I unfortunately can’t send any files for policy reasons, even after de-identification… I appreciate the time you’re taking to try finding a solution :slight_smile:

I better understand how files are managed. I suppose the best solution is to retag files to construct time points. For the T1 mapping, as it consists of 3 separate acquisitions, there is no common series with different time points for the same slice.

The only frustrating thing is that I succeeded to obtain the right sequences in SequenceBrowser. There is only a small link missing !

Thanks again :slight_smile:

Did you try selecting all 3 series using Shift+click, and then parsing them in DICOM Browser?

If you enable the “Advanced” view then you should be able to see the loadable for both “MultiVolume” and “Volume Sequence”. Could you attach a screenshot of the Advanced section after you clicked Examine? (scratch out patient name/id from the image but keep the rest of the “DICOM Data” column content)

Sorry for the late answer. I don’t have access to the images during the weekend.

I found that one of the 3 series I tried to merge had a different size. This is why no “MultIVolume” was recognized. Even when I resize the “wrong” volume, it doesn’t suggest a MultiVolume node.

However, if I chose the two “correct” volumes (with different flip angles). A MultiVolume is recognized.

image

There might be some mess in the DICOM Tags after resizing the “wrong” volume… It won’t be easy to correct them, and even though, I might obtain an incorrect mapping.

Thank you for your help!

1 Like