I am new to slicer,as I am installing it on my ubuntu 20.04 system after installation it crashes immediately and shows error as follows:

Operating system: Ubuntu 20.04
Slicer version:4.11
Expected behavior: Work well
Actual behavior: Gives error
error: [/root/Bhagyashri/Slicer-4.11.20210226-linux-amd64/bin/SlicerApp-real] exit abnormally - Report the problem.

Be sure the prerequisites are installed: Getting Started — 3D Slicer documentation

Thanks Steve Pieper… I installed the prerequisites. Although there is error. Please help me

I use 20.04 with no problem, so it’s probably something with your LD_LIBRARY_PATH or other config. You can try running Slicer --launch xterm and then run SlicerApp-real in the new window to see if there is more diagnostic info. Also inside that window you can try ldd $(which SlicerApp-real) to see if any of the core slicer or python libraries are pointing outside of your install tree.

Thanks pieper…I have error with SliperApp -real as below:
Switch to module: “Welcome”
error: [/root/Bhagyashri/Slicer-4.11.20210226-linux-amd64/bin/SlicerApp-real] exit abnormally - Report the problem.
which version of qt you are using

No module named sysconfigdata–linux X86-64–linux-gnu

I removed this error No module named sysconfigdata–linux X86-64–linux-gnu…althrough there is same problem .I tried many different versions of qt…but slicer crashes with SlicerApp real…please help me

Qt libraries, along with all required dependencies are distributed. You should not have to install Qt.

This seems to indicate the application started but it crashed once the Welcome module is loaded.

Could you try:

./Slicer --modules-to-ignore Welcome

Does the application start ? Are you able to select other modules ?

This may not be the issue, but is there a reason why you install this in root? Are you running the application as root?

tried it same problem exists…application does not start immediately crashes after installation

1 Like

I tried not in root but same problem is there