Import segmentation from model is too coarse

When I open a closed surface model and attempt to import it into the segmentation the resulting segmentation is very coarse and doesn’t match the voxel resolution of the background image volume and I don’t see a way to edit the resolution.

how can I get the reslution to match the background image?
see the image the blue is the segmentation based on the background image and the yellow is the segmentation from the imported model.


Reference geometry is not defined for a new segmentation, only if you edit a segment in Segment Editor with a master volume specified. In that case the resolution will be 1x1x1mm^3.

In the current version the only way to specify the geometry in such a case is like this:

  • Make the closed surface the master representation. You can do that in the Representations section in the Segmentations module
  • Long-click the Create button in the row of Binary labelmap
  • Click the only path in the top half of the popup window
  • Click the “Set geometry from volume” button in the bottom half, in the row of Reference image geometry
  • Set the volume you want the geometry to come from

We should really rework the reference geometry part of the user interface, but it has never reached the top of the priority list up to this point. At the least probably we should allow selecting a reference volume in the Advanced section of the Export/import panel when we import models. Currently it’s only enabled when exporting labelmaps. @kayarre and @lassoan what do you think?


2 posts were split to a new topic: How to import/export segmentation as nrrd file?