Segment has invisible bounds smaller than master volume

when I am editing a segment there appears to be an issue with the invisible ROI that bounds the limits of what is included. I can’t figure out how to make this invisible roi larger.

this picture depicts an exaggerated case, its obvious that its bounded by a box.

image

I think the problem is that when you import from a model it sets the pixel size a default, so you get what looks like a nicer resolution, but then the pixel dimensions aren’t large enough.

The master volume determines the editable area. The volume that is set when you add the first segment is the one that’s used for the geometry. You can either start it over, or change the geometry using the small box icon next to the master volume selector. Available in 4.10.

I tried this and it appeared to not let me edit it directly, I would like to be able to “simply?” increase the geometry size? I can change the spacing of the source geometry but not the dimensions or origin.

I tried the upsampling from a different volume to match the same spacing and slicer appears to freeze, or die (will investigate steps to reproduce further)

Segmentation is about identifying regions in a volume. It doesn’t make sense to paint outside the image you want to segment. So simply choose the volume you’re segmenting and the editable area will match it.

1 Like

@cpinter but the resolution is not the same.

on import:
image

on modifying the source geometry:
image

I am thinking that the import giving this refined “looking” mask is setting my expectations to high.

My work around:

  • export the segmentation to a labelmap
  • crop volume and expand the ROI to create new volume that is bigger than the bounds of the imported segmentation.
  • Threshold this label map such that the whole of the image is included
  • import this label map into the segmentation node
  • apply something that will grow the region, margin, hollow… etc
  • observe the bounds of the segmentation are larger than initial import segmentation

If you use a recent Slicer version, you can set very high resolution for your internal labelmap representation and set any region size. To specify an arbitrary region size, create an annotation ROI node and choose that as “Source geometry” in the Segmentation geometry popup.

image

You need to use oversampling in the geometry widget. Choose the volume and increase oversampling to 2 or more if you need. Then the bounding box will be the same but the resolution will be higher.

However you have a volume node so it’s much simpler to use that with oversampling and possibly isotropic spacing.

I tried this but in some instance it causes slicer to crash. (still need to refine those steps to reproduce)

The only limit to segmentation’s resolution is the amount of memory you make available (on Windows you can increase virtual memory in your computer settings, on Linux it is called swap size, on Mac you need to have plenty of free disk space). If a process runs out of memory, it crashes. So, as a general rule I would recommend to have 10x more memory available than your data set size. If you set a small voxel size then you may need tens of GB of memory - preferably physical RAM, but at least virtual memory.

1 Like

@lassoan That makes sense and is a possible cause, I do have a 64Gb memory machine so I guess I would be a little surprised by that, but I haven’t checked and would make sense. (It’s amazing how easy it is to run out of memory these days)

also: Thank you so much for your support @lassoan and @cpinter, You have been super responsive and helpful. I really appreciate all the hard work and help. most and best help I have gotten from any open source software out there.