Importing US works for data import but not as dicom import?

I would like to understand why this doesn’t work. I have an ultrasound scan stored as a dicom file. I have followed the thread of a very similar case involving ultrasound but it gives the same error after installing the Slicer Heart extension.

if i instead import it as data, it has no issues and can be manipulated as expected.

it would be easiest to work with if i could import this as dicom data, and it looks like it should be possible. If anyone can tell me how to load this through dicom it would be much appreciated.

not sure that it will help, but here is the dicom import log:
Imported a DICOM directory, checking for extensions

Warning in DICOM plugin Scalar Volume when examining loadable 1: Unnamed Series: Multi-frame image. If slice orientation or spacing is non-uniform then the image may be displayed incorrectly. Use with caution.

Reference image in series does not contain geometry information. Please use caution.

Loading with imageIOName: GDCM

Could not read scalar volume using GDCM approach. Error is: FileFormatError

Loading with imageIOName: DCMTK

Could not read scalar volume using DCMTK approach. Error is: FileFormatError

Could not load: 1: Unnamed Series as a Scalar Volume

If you load the DICOM file using “Add data” dialog then it’ll basically ignore all metadata and load the entire image stack as a 3D volume using ITK library’s DICOM reader directly.

If you import the file into the DICOM database and load using the DICOM volume, then there is a much more sophisticated mechanism, which inspects the file content, evaluates many different ways have the data set can be interpreted, performs consistency checks, etc.

Your data set does not seem to fit any of the profiles currently offered by the more sophisticated and reliable DICOM file loading mechanism. Based on “FileFormatError” message, the data set may have some low-level data encoding error (maybe due to trivial things, such as international characters, or maybe due to corruption caused by anonymization). To investigate this, we would an example data set. The data set must not contain any patient identifiable information; should preferably taken of some test object or animal case.

ok, I’ll give you the sample i’m working with. It was anonymized before I got it, so that should be fine. I have also attempted to run it through the dicom patcher module with the same result.

here is a link the original anonymized data:

Hi @EricWilson -

Thanks for sharing the example data. It’s a mutliframe ultrasound image and it looks pretty standard, but it’s not something Slicer currently supports via the DICOM module.

I’ve written a custom script for a similar dataset in the past, and that could be used as a start point for making a dedicated plugin.

The issue is that most of these datasets will be ultrasound cine and not volumes (and usually there’s no way to tell automatically). We should probably give the user the option of loading either a scalar volume or a sequence when this type of data is loaded through the dicom module.


thanks for the information and the code. I should be able to make a solution with this.

Super - post back if you come up with anything that could be of general use for people with this kind of data.

1 Like

@EricWilson, did you ever manage to make up a solution for this? I am also hoping to load US cines.

@sonjapejcic US cines can be loaded if they are in the format of Nrrd(Nhdr+raw) or MHA(mhd+raw) using the Sequences extension which can be downloaded and installed from the Extension manager.

hopefully @jamesobutler’s response helps. the data set wasn’t really in the format we were looking for, so development working with US was stopped until we can get access to the relevant format.