Inability to export segmentations as RTStruct File

Slicer Version: 5.2.1 (Stable Release)
OS: MacOS Big Sur 11.7.3 (Intel i7)
Expected Behaviour: ‘Export as DICOM’ in Export Data converts scene to DICOM files and segmentations to RT Structure file
Actual Behaviour: DICOM files are created but RT structure file is not created


I am a radiation oncologist and just beginning to explore 3DSlicer for integration into our research workflow.

I saw the video by Dr @lassoan on exporting segmentations to DICOM and RT Structure files (Create DICOM files from CT volume and segmentation - YouTube). I have the SlicerRT and QuantitativeReporting modules installed as well. Following along the video step-by-step, unfortunately after hitting ‘Export’, the output folder contains the DICOM files, but not the RT Structure File.

Before posting here, I scanned through all posts related to this topic, but most dealt with problems with RT Structure files, rather than the process of exporting it. At present, I am performing a clean install of Slicer, using the nightly release (v5.3.0) and also attempting to recreate the problem on a Windows machine. [Update: Tried this step, but no luck. DICOM files are still exporting, but no RT Structure file.]

I am also aware that as a format, RT Structure, is considered a legacy format. But its a core component of Radiation Oncology workflows.

Thank you for your help in advance.

Can you please make a screenshot of your Data module (Subject hierarchy tab) before starting DICOM export?

Thank you for your reply & apologies for my delayed response.

This is the subject hierarchy screen

Here is the export selection screen after I have selected ‘Export to DICOM’

Am I doing something wrong?

I can also confirm that this is not an issue on Windows-based systems. The RT structure file is created as expected.

Please attach the log after export fails on Mac. Maybe it contains some pointers.

Thank you for your reply @cpinter. I’m not sure when you say ‘log file’. I actually don’t get an ‘export failed’ message. The DICOM files are generated successfully, but the RT structure file is not!

You can find the log in View / Error Log or Help / Report a Bug. Basic information such as what is the log file can be found easily in the forum or the Slicer documentation, so I encourage consulting these material for help.

Thank you for your suggestion @cpinter. I did as you suggested and discovered that I need to save all my data into an MRML scene first, quit the scene and then reload the MRML scene. Then after exporting as RT structure set, it creates an RT_Struct file.
My next task will be check the compatibility of these RT_Struct files with our manufacturers’ Treatment Planning Software (TPS).
Thank you for all your responses.

I can also confirm that the RT_Struct file from Slicer imports perfectly into Varian Eclipse TPS.

Will add to this list in the future.

I think it would be much better to fix this issue rather than do the save/load workaround. Can you please help with this by sharing the error log that you get after a failed export attempt?

The last step in this sequence was when I switched to the Data Module and rearranged the hierarchy as demonstrated in your video. Upon hitting export, nothing gets logged and I got only DICOM files (no RT_Struct file).

I then closed the previous scene. I next loaded a scene, which I had already worked upon, and repeated the export procedure and it behaved as expected.

I find it very strange that there is no error or warning in the log. Do you have access to a Windows or Linux machine to try the same thing? To see if it’s OS specific or not. Also is there any special data involved? Can you reproduce it with data from the Sample Data module? Thanks!

It does appear to be OS Specific. I tried the same steps on Windows, with no issues whatsoever.
All of the above was performed on the datasets from the sample data module. No special data was used.
Thank you for you help @cpinter!