install pyradiomics via conda

Hi there,

I was trying to install pyradiomics by the command line ‘conda install -c radiomics pyradiomics’. However, it reported:

  • pyradiomics -> python[version=’>=2.7,<2.8.0a0|>=3.7,<3.8.0a0|>=3.6,<3.7.0a0|>=3.5,<3.6.0a0|>=3.4,<3.5.0a0’]

Your python: python=3.8

Then I create another env with python =3.7, it reported :slight_smile:Specifications:

  • pyradiomics -> python[version=’>=3.8,<3.9.0a0’]

Your python: python=3.7

Besides, it also reported that :slight_smile:The following specifications were found to be incompatible with your CUDA driver:

  • feature:/win-64::__cuda==10.2=0
  • feature:|@/win-64::__cuda==10.2=0

Your installed CUDA driver is: 10.2

I also tried python3.5 but it reported same error as 3.7. Does anyone know which python version do I need?

For the error about cuda version, I didn’t read on the intro of pyradiomics required specific cuda version, is that related to the failure of instllment as well? Thanks for helping!!

Currently, conda installation of PyRadiomics is providing errors. See also this issue and this issue on the PyRadiomics github. For Python 3.7, there are also distributed wheels available (i.e. pip install pyradiomics). Finally, PyRadiomics is installed as part of the SlicerRadiomics installation, therefore there would be no need to install it in the slicer environment.

Questions/issues regarding the standalone version of PyRadiomics are also handled on the github issue tracker of the PyRadiomics repository.