Internal error : Bad array new length

Hello Slicer Team,
Today I run into the issue ‘Slicer has caught an internal error.’

The message detail is:

Exception thrown in event: bad array new length

i was running a batch script to generate a 3d model using seed grow segmentation, first i got this issue i’m attaching a log file here , so i rerun the program and it worked as usual normal and created the output .

My Question is , is there any setting to avoid the internal errors and give slicer whatever the memory or source it requires and use it at its full potential?
https://filebin.net/ehx1iicfhm4on7um

MemoryError: std::bad_alloc: bad allocation is the first serious error and it typically means that you run out of memory. How large the image is that you are trying to load?

There are lots of OpenGL errors in the log. What CPU and graphics card does this computer has?

Hundreds of issues have been fixed and improved since your Slicer version was released. Could you try if the most recent Slicer Preview Release works well?

Sounds Good, i’ll try to update the slicer version, and get back to you.

I’m using Xeon E5-2690.

thanks

Sandy bridge processors were released almost 10 years ago. Slicer requires computers that are not older than about 6 years.