Issue loading .nii files onto 3D slicer

I am having issue loading/viewing my .nii files onto my computer.

*I was able to view and view my .nii files on itk snap, so it doesn’t seem to be a data problem

  • I loaded some example .nii files that I downloaded online onto 3D slicer and they were able to be viewed as well.

I am running on a OS X and using version 4.8.1 r26813.

Is there a way to troubleshoot this and view my files?

1 Like

What did you do exactly? What did you expect to happen? What happened instead?
Could you also try with latest nightly version of Slicer?

I converted my data from sti to nifti. Data size for each nifiti file is 73.7 mb. I tried drag-and-dropping the files, but I could not view the images at all. I believe I am running on the nightly version (downloaded original, then downloaded the nightly version last night). I also tried loading the nifti file onto the file directory and I am still not able to view it.

I was expecting to view my nifti files when I dropped them (see video). My .nii files are able to be viewed on other softwares. I was also able to view other fMRI .nii files that I found online. I can upload some of my files on dropbox, if that works as well

https://www.dropbox.com/s/ygir8ance23iiwl/nii_example_vid.mov?dl=0

nii_example_vid.mov

www.dropbox.com

Shared with Dropbox

Thank you,

Richard Joaquin Ortiz, B.S.

R.I.S.E. Pre-Doctoral Fellow, Biological Sciences

Department of Biological Sciences

Dr. Cushing Laboratory

The University of Texas at El Paso

500 West University Ave

El Paso, TX 79968

rjortiz2@miners.utep.edu

Phone: 915.731.3354

Please share a dataset, and how you converted the files to nii. (make sure there is no patient information in the files or filenames)

If you can’t share data, then please check the error log and share it:

https://www.slicer.org/wiki/Documentation/Nightly/SlicerApplication/ErrorLog#To_capture_the_entire_error_log_for_a_report

nii. file

1 Like

Drag-and-drop worked for me (i have latest nightly build), but it is 4D image (probably fMRI of mice looking at a cheese or a cat). To load the image as 4D put it in a separate folder, go to
MultiVolumeSupport->MultiVolumeImported
select folder, create new multi volume, click “Import”
Go to MultiVolumeSupport->MultiVolumeExplorer, move slider or “Play”

Screenshot%20at%202018-10-18%2003-25-12

1 Like

Yes, the first volume of both loads fine for me (even in 4.8), but as @Mihail_Isakov says you will need to use MultiVolume to browse as a 4D volume.

That said, if you run in to issues converting via the intermedia STI step, you might want to try: https://github.com/neurolabusc/Bru2Nii

2 Likes

Awesome!

I was able to upload the files needed!

Thanks!

1 Like