Landmark registration shows just white page

Operating system:64 bit
Slicer version:4.11.20210226
Expected behavior:
Actual behavior:

When I click on Landmark registration I am getting this type of error that the page appears white, and I cannot click anywhere.

I do not know why is it occurring now because I have used so many times before this volume

Hmm, can you share the error log?

Any error log appears, it´s like only this volume is not working. If I click in all the other modules, it works properly.

I have restarted the computer but the same. I´ll try to re-install it.

Here’s how to look in the error log:

Oh, I understand; here it is the error log:

Yes, that’s the error log and it shows where the failure happens but it’s not clear why. Can you try the latest SlicerPreview version? If this is specific to a given volume or you can otherwise give step-by-step details about how to reproduce the error we can look into it.

I have tried with the SlicerPreview Version and it is still happening the same. The steps that I follow are these ones:

I click on Add Data and I upload two .mha volumes

When they are uploaded I am able to see all the slices and the misalignment between them.

Then I go to Registration and I click on Landmark Registration. And a popup says to pick the volume to register, so I click on them on the fixed volume and moving volume and when I click on Apply is when the right part of the page appears in white.

But I am able to see all the other volumes, and to click in all parts, except the options of the Landmark Registration where I have to add Landmarks and select the refinement etc.

Does anyone have an idea of what is happening?


Do you get the same behavior if you use the sample data? E.g. the pre-post dental surgery CBCT scans are a good test case. Perhaps there’s something different about your mha files? Can you share them or describe them?

The problem is solved!

The day I started having the error, I was trying to change some parameters by clicking on the slice spacing button that is on the screen of each view of the volume.

Today I have clicked on View and then to Restore to default and the Landmark Registration is working properly.

I think that maybe this was the triggering point of this error.

Hope this can help to others.

Thanks for your help

1 Like