Loading of GE/Kretz ultrasound volumes (.vol file)

I’ve checked the data set and unfortunately it is a compressed Kretzfile. You can open it with GE 4D View but even (at least my version) can only save it compressed. You may be able to open it using Image3dAPI, if you get KretzLoader.KretzImage3dFileLoader plugin from GE (you need to sign up for the Edison developer program as described here).

Thank you for looking into this Andras!

A post was merged into an existing topic: Anyone know how can i export a 3D volumen from Mindray M6 ultrasound in DICOM format to use in Slicer?

I have .V00 files and I would like to extract Cartesian volumes. Using 4D View I cannot open the file, it begs the following information “Cannot decompress file”. Any suggestions?

If 4D View cannot open the file then the file may be corrupted. You can still try to load it using SlicerHeart extension: install the extension and follow these instructions.

Well, I am using the 4D View Free 60-day demo version and I don’t have an ultrasound machine. That may be why I cannot import the files.
I received the anonymized data from a doctor and what I want is to extract Cartesian volumes to do finite element analysis.

Unfortunately, ultrasound imaging vendors generally don’t want to make it easy for users to access to 3D/4D ultrasound images because they don’t want to make an effort to support this and/or they want to lock you into using their proprietary software. Therefore, usually you need to spend some time with experimenting with various options to figure out a way to get to the data.

You may ask the doctor to try to save or export the data in all possible formats that the image acquisition software supports.

Are you trying to load cardiovascular or ob/gyn images?

I am trying to load ob/gyn imagens.

A post was merged into an existing topic: Dcmfiletype.140 to stl or obj

Slicer can import Cartesian volumes but it needs to be in one of the supported formats (e.g., non-compressed KretzFile DICOM).

Then Image3dAPI will probably not help. If GE’s 4DView cannot load the image then you might be able to manually extract some data using RawImageGuess extension.

Hi

I have tried and read alot about 3D slicer. I have some issue opening a file. I have tried with sliceheart aswel, so I was hoping that you could help me to investigate the issue?
I cannot upload the file here.

I hope you have some time to help me with.

Best regards
Camilla

what is the difference with or without #ge ? where are the instructions ?
I have the same GE data, after loading througth “Add DICOM Data” button, I can not using the volume rendering.
Need help. thanks

You can check the application log for more information. It may give some hints about what’s wrong.

The instructions for loading .vol files are available here.

You need to first successfully import the image. Follow these instructions for loading .vol files files and if it fails then check the application log for details.

1 Like

Hello, I’m starting the fetal ultrasound part, and I have some doubts, following the youtube video tutorial, I installed SlicerHeart and it doesn’t stay, Desciption the “GE Kretz ultrasound volume”, only the “Volume”, what to do? Thanks