Markups Jump Slices functionality is broken on preview

Tested with latest preview on Linux. Clicking on the control points do not jump the slice view to those coordinates.
There is no error message that I can see.

@smrolfe @lassoan

For me clicking on rows in the control points table does not respect the “Jump Slices” option in the Markups module. However, clicking on the control points in the slice view does work except that it always does the “Jump slices - centered” option.

It is a bit unclear to me what the difference might be between the jump slices option in the “Crosshair Selection” toolbar and the jump slices option in the markups module. Does the toolbar method change what happens when you click on the point in the slice views? If so, it doesn’t appear to respect that option.

Indeed, “Jump slices” in Markups module is indeed broken in the latest Slicer Preview Release. It would be great if @smrolfe could fix this before Slicer5 is released (as always, within 1-2 weeks).

Other things seem to work as intended:

  • Jump slices option in the Crosshair toolbar button controls how the slices are moved if the crosshair is moved (using Shift+MouseMove). By default, “offset” mode is used so that Shift+MouseMove can be used for slice browsing.
  • Clicking on a control point in a slice view always uses “centered” mode, as typically you want to see that point and “offset” mode does not guarantee this (even if the point is visible, it may be very hard to find if not centered and there are other points in the same plane).

Thanks, I am looking into this (and the ROI color issue) now!

I submitted a fix for the broken “jump slices” function and a related bug in the pull request:

1 Like