Model to Model distance computation is "completed with error"

Dears in 3D Slicer support,
I am experiencing and old problem: when using Model to Model distance it is suddenly ending with this message: completed with error.
the version I am using is 4.11…2021.0226 ( I am using this as I am used to use this version)
How could I solve this problem, and if can not be solved what is the replacement on the new release version of the 3D Slicer.
Thank you so much in advance.
N.B.: Below is the link to the debug word file and screenshot.

1 Like

Click the two down arrows next to the message to open a box with the specific output and this should help you narrow down why it’s not working. Perhaps this model is too complex.


The attached log file includes the information that is shown when the double-down arrow is pressed:

[DEBUG][Qt] 16.06.2022 18:56:07 [] (unknown:0) - Found CommandLine Module, target is C:/Users/Mohammed Al-watary/AppData/Local/NA-MIC/Slicer 4.11.20210226/NA-MIC/Extensions-29738/ModelToModelDistance/lib/Slicer-4.11/cli-modules/ModelToModelDistance.exe
[DEBUG][Qt] 16.06.2022 18:56:07 [] (unknown:0) - ModuleType: CommandLineModule
[DEBUG][Qt] 16.06.2022 18:56:08 [] (unknown:0) - Model To Model Distance command line: 
C:/Users/Mohammed Al-watary/AppData/Local/NA-MIC/Slicer 4.11.20210226/NA-MIC/Extensions-29738/ModelToModelDistance/lib/Slicer-4.11/cli-modules/ModelToModelDistance.exe --source C:/Users/Mohammed Al-watary/AppData/Local/Temp/Slicer/BFJCA_vtkMRMLModelNodeE.vtk --target C:/Users/Mohammed Al-watary/AppData/Local/Temp/Slicer/BFJCA_vtkMRMLModelNodeF.vtk --output C:/Users/Mohammed Al-watary/AppData/Local/Temp/Slicer/BFJCA_vtkMRMLModelNodeDA.vtk --distanceType signed_closest_point
[ERROR][VTK] 16.06.2022 18:56:14 [vtkSlicerCLIModuleLogic (000001E5D0E3E050)] (D:\D\S\Slicer-1\Base\QTCLI\vtkSlicerCLIModuleLogic.cxx:2126) - Model To Model Distance terminated with a fault.

Unfortunately, this is not very informative, only shows that Model To Model distance module crashes early.

First of all, try with the latest Slicer Stable Release and see if the problem still occurs.

If it does, then a good next step would be to share the input files with us. To do that enable the developer option of preserving CLI module data files (in menu: application settings → Developer → enable Preserve CLI module data files), then upload to dropbox/onedrive/gdrive the source and target files that are mentioned in the application log; and post here the link. We’ll then see if we can reproduce the error on our computers.

1 Like

I also get a “completed with errors” message:

I have tried this with the latest stable release with the same result. Am going to try with some models that I know do work, but in the meantime, does anyone have any ideas for a solution?

^^ Answered my own question - I was using .vtk file (volumetric mesh) rather than .stl (surface mesh). It’s working fine now that I’m using .stl