Models always shaded flat regardless of interpolation

This is quite possibly a misunderstanding on my part. It looks like models are always shaded with flat polygons, and the interpolation setting has no effect. Regardless of the setting (Flat, Phong, Gouraud), all polygons are flat (see image below). This is using the “Lights” module, set to Default lighting. Shouldn’t Phong or Gouraud interpolation result in a less “faceted” appearance or am I mis-remembering how these work?

Thanks!!!

-Hollister

Preview 2021-12-19, MacOS, MBP 16" AMD Radeon Pro 5500M 8 GB.

Sharing requires surface normals. They can be computed in Surface Toolbox module.

Moat mesh file formats allow storage of surface normals. What file format are you reading your model from? What software has created the file?

It’s a segment converted to a model in Slicer. I computed surface normals in Surface Toolbox and it shades smoothly now - thanks!

I was a little confused because Gouraud shading doesn’t require normals (but Phong does). Anyway, thanks for the help!!

-Hollister

To clarify, Gouraud shading uses normals at the vertices to calculate lighting and then interpolates the colors across the triangle, Phong shading interpolates the normals and recalculates the lighting per-fragment across the triangle. So both require vertex normals. STL format, for example, does not save normals, so they need to be re-calculated for smooth rendeing.

1 Like

In current Slicer versions, surface normal computation is enabled by default, but you can enable/disable it by adjusting segmentation representation conversion parameters:

Got it, ok. I thought Gouraud interpolated vertex colors across the polygon and didn’t use normals.

My undergrad computer graphics class was an embarrassingly long time ago.

1 Like

Ah, okay - Thanks, Andras!