Modify stl object


I am using Slicer version 4.11.20200930 on Ubuntu 20.04 OS. I have imported electrode leads as STL objects from a Matlab-based toolbox and noticed that the black/white colour coding for contacts and inter-contact gaps were missing. However, when I had changed the opacity, it seems that markings highlighting the boundaries for the contacts and gaps are present.
Is there a way to replicate the electrode lead black/white colour coding scheme for the Slicer scene? I’ve attached a few pics to illustrate.



STL is a simple format that doesn’t support surface coloring. It looks like there are internal polygons in the model you see when you change the transparency. Maybe the easiest is to find a way would be to export a .vtk in polydata format with surface scalars and enable them in Slicer’s Models module.

Thanks for your suggestion. The only other format option for export is PLY. However, the result is the same when viewed in the Slicer scene.

Did you try enabling scalars for the ply file? They might be there.

Otherwise you’ll need to come up with another workaround, like adding additional models in the right place and putting them all in the same transform.

1 Like

Thank you very much, this worked perfectly!