Mouse swipe translates view/3D unintentionally -- please help

Brand new to Slicer (4.13, Intel MacOS Catalina) and I’m having the following problem:

I have a volume loaded, and I’ve been working mostly in the Segmentation Editor. I’ve found that click+drag rotates the volume (in 2D or 3D panes), and Shift+click+drag translates the volume.

However, when I simply single-finger swipe on the trackpad, this ALSO causes the volume to translate (no Shift, no click). Usually it is the first time my cursor enters the view window of interest, then I wait a few seconds and do the exact same single-finger swipe, and nothing happens. This is driving me crazy because I am trying to segment and the minute I move the cursor over to what I want to trace, the volume moves. (It happens regardless of whether I have selected a segmentation tool or whether I’m just mousing over with the regular cursor).

I looked for the answer to this problem in the documentation (User Interface — 3D Slicer documentation), I could not find the answer. Please help me, and thanks!

Tap-and-drag gesture is by default mapped to panning of the view (same as Shift + click-and-drag). This gesture requires that you tap your touchpad and then rest your finger there for a half second or so without moving. This normally does not interfere with the click-and-drag gesture.

Maybe you have enabled tap-to-click on your system? Or maybe you click in an unusual way (maybe you recently moved from another operating system, or switched from mouse to trackpad, …)? Or maybe something has changed in macOS (there have been some recent related macOS bug or maybe there was some intentional change).

If more people will report this error then we will change the event mapping, but until then you can disable the tap-and-drag by copy-pasting the text below into your Slicer startup file:

for sliceViewLabel in
    sliceViewWidget =
    w = sliceViewWidget.sliceView().displayableManagerByClassName("vtkMRMLCrosshairDisplayableManager").GetSliceIntersectionWidget()
    w.SetEventTranslation(w.WidgetStateIdle, vtk.vtkCommand.StartPanEvent, vtk.vtkEvent.AnyModifier, vtk.vtkWidgetEvent.NoEvent)

@pieper @fedorov @che85 (and anyone else using macOS) - do you find that you accidentally activate tap-and-drag gesture when you use paint effect in Segment Editor?

I don’t recall ever having this trouble with the mac trackpad, but I don’t think I have tried using slicer with a trackpad in several months so maybe it’s something new.

I haven’t noticed this at all. I use the touchpad sparingly (you can have my 3 button mouse when you pry it from my cold, dead fingers) but I just ran through some painting with the touchpad just now and it seems fine. This is MacOS 12.1, 2019 MBP 16". I don’t have any funky touchpad settings or gestures.

Hi all,

Thank you, editing the worked!
(No, was not new to trackpad and no, no tap-to-click set up on MacOS – will be interesting to see if other MacOS/trackpad users note this issue)