MRI image loading problems: nothing visible on any of the slicer windows/scenes after loading

Operating system: Windows 7
Slicer version: 4.6.2 & 4.5.0-1
Expected behavior: series of MRI images visible on different slices
Actual behavior: I’ve imported the DICOM data on slicer and it takes a while as expected. It shows that the data has been imported successfully. But after loading the data, nothing is showing up on either of the slicer windows (red/yellow/green). It’s not showing any error message, but nothing shows up on screen/slicer windows.

I tried to load the data by choosing the directory of my files (Choose Directory to Add). Slicer window keeps changing while loading the data and seems like it’s loading all the slices (around 2200 slices). But finally it shows only one single slice, not the series of MRI images.

I tried it with two different versions of 3D slicer (4.6.2 & 4.5.0-1), but both of them are showing the similar behavior. It will be great if anyone can help me out.

Thanks in advance!

Hi -

Try reviewing the steps in the FAQ:

If you’re still having trouble, send some more detail about the type of data and the error log (edit out any patient info)


You can also try if the problem is solved in the latest nightly version.