Multiple errors about SimpleITK, LibArchive, python when I build Slicer

I used
CMAKE 3.19.8
Visual Studio 2019 x64 tool v142
And refer to

I first installed and compiled
ITK DCMTK SlicerExecutionModel ZLIB
And join them in CMAKE-GUI
The following is my CMAKE interface

I used the Release mode to build
Then here is my error list
I want to know what I should do to successfully build Slicer
Thank you for your patience to read this

You previously posted on the following thread. Did the solution provided there solve the issue?

I do see in one of the logs you posted that it warns the following:

warning C4819: The file contains a character that cannot be represented in the current code page (950)

Sorry this is my fault. I emptied the old folder before this construction, which caused the same error to reappear. I have fixed it, thank you
This is the file I rebuilt, and the error is reduced to 9
Below is the new list

Most probably you have run into this issue:

A workaround is to temporarily rename your other Python installation folder (anaconda, etc.). You can rename it back to the original name after Slicer build is complete.

I tried the method you recommended, and successfully built the Release and Debug of Slicer. Thank you for your answers!

1 Like