Ndi polaris failed to connect with plus

Operating system: windows 10, or ubuntu 16.04
Plus version:2.6 or 2.7

I have an ndi polaris camera. It has a com port and is connected with the pc through com-usb adapter. The pc recognize it. But still cannot connect with plus. I choose “ndi polaris tracker with passive markers” as configuration xml file. and I tried to type “Serial Port = the com port number i have” but still no connection. Do you have ideas especially for this kind of Polaris camera connection?


See Andras’ response – better to provide necessary information over there and keep discussion in one thread.
What brand of com-usb adapter? In my experience the only ones that worked correctly were FTDI chipset.

Please report this at https://github.com/PlusToolkit/PlusLib/issues

1 Like

I’m using the prolific one. My OS is windows 10. I also tried in ubuntu 16.04. the com is recognized in my pc but cannot connect with plus. I can also connect with other programs (like MITK) but not with Plus. Do you think using the FTDI one will solve the issue?

If it works in MITK then it’s probably just a problem in the PLUS configuration. I suggest to open an issue at https://github.com/PlusToolkit/PlusLib/issues as Andras mentioned.