No Train Tab/button in Slicer monailabel module

Dear Experts,

Thank you for the Automated segmentation modules including monailabel.

I am working with Slicer 5.0.3 on Ubuntu 22.04 and look forward to train/refine models for use on local datasets, however the slicer monailabel module lacks the “Train” and “Stop” tabs/buttons under the “Active Learning” field.

I do encounter some “Traceback…” error, but slicer application launches seemlessly.
Please find the error messages below:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/ac/ApPz/Slicer-5.0.3-linux-amd64/lib/Python/lib/python3.9/", line 169, in load_source
    module = _exec(spec, sys.modules[name])
  File "<frozen importlib._bootstrap>", line 613, in _exec
  File "<frozen importlib._bootstrap_external>", line 850, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/home/ac/ApPz/Slicer-5.0.3-linux-amd64/NA-MIC/Extensions-30893/MONAILabel/lib/Slicer-5.0/qt-scripted-modules/", line 23, in <module>
    from MONAILabelReviewerLib.ImageData import ImageData
  File "/home/ac/ApPz/Slicer-5.0.3-linux-amd64/NA-MIC/Extensions-30893/MONAILabel/lib/Slicer-5.0/qt-scripted-modules/MONAILabelReviewerLib/", line 14, in <module>
    from .ImageDataController import ImageDataController
  File "/home/ac/ApPz/Slicer-5.0.3-linux-amd64/NA-MIC/Extensions-30893/MONAILabel/lib/Slicer-5.0/qt-scripted-modules/MONAILabelReviewerLib/", line 19, in <module>
    from MONAILabelReviewerLib.ImageDataStatistics import ImageDataStatistics
ModuleNotFoundError: No module named 'MONAILabelReviewerLib.ImageDataStatistics'
loadSourceAsModule - Failed to load file "/home/ac/ApPz/Slicer-5.0.3-linux-amd64/NA-MIC/Extensions-30893/MONAILabel/lib/Slicer-5.0/qt-scripted-modules/"  as module "MONAILabelReviewer" !
Fail to instantiate module  "MONAILabelReviewer"
The following modules failed to be instantiated:
Switch to module:  "Welcome"

I also tried launching Slicer nightly release to address this, however, this fails with following error:

/home/ac/ApPz/Slicer-5.1.0-2022-09-22-linux-amd64/bin/SlicerApp-real: error while loading shared libraries: cannot open shared object file: No such file or directory

Look forward to guidance to resolve these issues.

Thanks Again.

Best Regards,

1 Like

Hi - thanks for reporting.

The first issue about MONAILabelReviewer occurs for me too on linux, but it doesn’t have any impact on the MONAI Label module itself, so you can ignore that for now (although the packaging of that module should be fixed at some point). Could you file an issue to be sure the MONAI developers are aware of this?

Also the issue with the nightly was reported here and there’s a patch so I expect the preview will be fixed soon.

The source of your issue not having the Train and Stop buttons is that they only show up after you connect to a server. So you need to install and run MONAI Label server using the instructions here.


1 Like

Thank you @pieper for your prompt response.

The Train and Stop tabs/buttons are absent, even while monailabel server (installed as per instructions at is running.

@diazandr3s and monai team, seek your inputs on the same.

Best Regards,

And you clicked the button to fetch models?

Yes, had fetched the models.

Dear @amitjc,

This is a bit strange. How did you install the module? Have you tried another Slicer version?

Please try with the preview release and let us know.

Also, can you please post a print screen of the MONAI Label module with the missing buttons?