Not able to view CT images in 3 D slicer version 4.10.1

Operating system:Windows 10 x 64- based PC; Processor Intel® Core™ i5-2400 CPU @ 3.10GHz, 3100 Mhz, 4 Core(s), 4 Logical Processor(s); Installed Physical Memory (RAM) 8.00 GB

Slicer version: 4.10.1 stable releases
Expected behavior: after loading the dicom images in the slicer it should be visible as axial, sagital and coronal views in the red green and yellow frames
Actual behavior: I am trying to import the DICOM CT images on the 3 D slicer it will show the message that import is successful and I will click on respective Axial, Sagital and Coronal plane and click on load. But I am not able to view the CT images in these red green and yellow frames at all. It will show the default black screen only. Even after loading the DICOM images properly.

Kindly let me know that this issue is occurring due to any hardware faults with my system or any changes in the software I have to do to resolve the same issue.

I have a laptop of similar configuration but RAM of 4.00 GB. I am able to load and view the images successfully in that using version 4.10.0 of 3 D slicer. But same I am not able to do on my PC

Hmm, hard to say. If the same steps with the same data works on your laptop but not on your desktop PC then it does sound like a hardware issue, or maybe a driver.

Are you able to view the SampleData (e.g. the MRHead?). Also you could look in the error log (in the Help->Report a bug menu).

No I can’t view the sample data also . I tried to load chest X ray, MR head. None of them worked.

image.png

in error log I am getting this error

image.png

If you use a laptop with two graphics cards (an integrated and a dedicated), then it might be necessary to force Slicer to use the dedicated one.

Also you can try updating the graphics drivers if the above does not work.