one tensor missed after two-tensor tractography

#1

Dear all,

I used two-tensor tractography for my whole brain analysis and extracted several fiber tracts by drawing ROIs manually. Strangely, one fiber tract is now missing the first tensor in two scans although all of the scans were processed identically and there were no issues with the other tracts in the exact same scans. When I load the respective tracts in Slicer only one active tensor can be seen. Do you have a hint to solve this problem?

Best, Marlene

0 Likes

(Lauren J. O'Donnell) #2

Hi Marlene. Have you checked the whole brain tractography to make sure it has two tensors? It is possible to run UKF tractography with one or two tensors, so the first thing is to make sure definitely you have two tensors in the original tractography.

By “exact same scans” do you mean you processed the same whole brain tractography more than once to extract different tracts, and sometimes you did not get both tensors?

We also need exact information about what modules you used to do the processing.

0 Likes

#3

Hi Lauren,

thanks for your quick answer! I checked the whole brain tractography and somehow there is only one active tensor left in the two cases that are affected. Is it possible that one of the two tensors got enabled? I used the same brain tractography to extract different fiber bundles via different ROIs earlier but strangely the other fiber bundles of the same cases show two active tensors, although I always used the same whole brain tractography.

I used UKFTractography.py for the whole brain tractography and then drew my ROIs in slicer to extract different fiber bundles. For measurements, I also used the tool in Slicer.

Thanks for your help!

0 Likes

(Lauren J. O'Donnell) #4

Hi! Please let us know specifically how you are checking if there is one tensor or two. What module, what button, etc.

0 Likes

#5

I found out when I had a look at the output-file with the measurements where two cases had only values for one tensor and “NAN” for the values of the second tensor. Also, when I go to “Tractography Display” in Slicer and look at the “advanced display”, there is only tensor1 in the drop-down menu of “active tensor”. The other cases all show tensor1 and tensor2.

0 Likes

(Lauren J. O'Donnell) #6

This is unusual. Could you please explain exactly how you ran tractography with ukf? Inside slicer? On the command line? Were there any error messages? You may need to re-run this to check.

0 Likes

#7

I used UKFTractography on the command line in the terminal. Can you run 2 tensor tractography inside Slicer? I will re-run this step and get back to you as soon as it’s finished.

0 Likes

#8

Hello Lauren,

I tried to re-run UKFTractography on my personal computer again but the process was killed when I used more than 2 seeds per voxel. For 2 seeds per voxel the output shows again only one tensor. Is there a special command to make sure that two tensors are being calculated? I thought UKFTractography on the command line would always use two tensors. Is there a chance that the two tensors have been compressed and the values I get represent the mean of the two tensors?

0 Likes

(Lauren J. O'Donnell) #9

You have to specify to use two tensors on the command line. You can test quickly by seeding in a smaller ROI than the whole brain. --numTensors 2 on the command line should do this. Also, the default should be two tensors.

This sounds more like a problem saving the tractography output file. If there are disk access issues with the computer, because the second tensor is saved last, it may not get correctly saved. Please check your disk. Is it full?

0 Likes

#10

I re-run the process but unfortunately, I still only get one tensor even if I use --numTensor 2. Storage does not seem to be a problem as I still have plently of space on my disk. Do you have another idea?
Thanks, I really appreciate your help!

0 Likes

(Lauren J. O'Donnell) #11

Hi this is quite strange since it worked on your other datasets. Does this one have smaller voxels or more image slices? I am wondering if you are effectively seeding more times and running out of computer memory?

0 Likes

#12

Hello Lauren,
computer memory might be the point! The process was killed earlier when I used more than two seeding points which would support this theory. Is there a way to find out for sure?
Actually, I processed all scans on a computer at the PNL last year and wanted to re-run the process on my computer now but it is still strange that two of the “PNL scans” have been saved with only one tensor.

0 Likes

(Lauren J. O'Donnell) #13

Hi. On the other computer this may have been a disk or memory issue. It sounds like your current computer is not able to run this. I recommend using a bigger computer to re-run those last two.

0 Likes

#14

Hi Lauren,
that’s sad news but thanks a lot for your expertise which I appreciate a lot!
Best, Marlene

0 Likes