Only black slices upon importing nrrd from 3DSlicer

Hello there,

For a project I need to disassamble a nrrd-stack to separate tifs. I tried to accomplish this using Fiji (ImageJ2). Upon the import of said nrrd showing the segmenation-mask of tissue generated with 3DSlicer, I get a stack of all-black slices. The problem persists with other nrrds from the same project.

Importing foolc.nrrd gives a 3-pixel-wide gray-scale stack, which viewed orthogonally depicts a person. So I guess this is a 3DSlicer specific issue.

Thanks in advance for any help!

I don’t see any issue here. You provided a 3D volume (all dimensions are spatial) and Slicer loaded it as a 3D volume.

If you want to load it as an RGB image then you need to specify the number and kind of dimensions accordingly:

# Complete NRRD file format specification at:
type: unsigned char
dimension: 4
space: left-posterior-superior
sizes: 3 128 128 1
space directions: none (1,0,0) (0,1,0) (0,0,1)
kinds: vector domain domain domain
encoding: gzip
space origin: (0,0,0)
data file: foolc.raw.gz

Note that you can directly load TIFF files to Slicer (single file or entire stack) - see here.

SOLVED: I had to change the Look-Up-Table to 3-3-2 RGB.