Problem about image are not equally spaced

Hi,

I was trying to import patient images, however, I got the warning after I clicked “examine”. Before I loaded the images, I enabled the “DICOMScalarVolumePlugin” as the warning suggested, but the image still appeared distorted not only in sagittal, coronal direction, but also seems to be disconnected in axial direction. Could you please help me solve this problem?

Many thanks,
Tingting!

DICOMiMPORT|690x81 PNGDICOMiMPORT

Please follow suggestions described in DICOM faq and let us know what you’ve found.

Hi Andras,

Thank you. Based on the warnings that I receive when I was using the DICOM module and the DICOM faq you recommended, I modified the application setting, change the acquisition geometry regularization to “apply regularization transform”, I also tried different reader approach. However, I still got the distorted images. Below are the images and the error logs.

Regards,
TingtingDICOMiMPORT_2

PNG

ErrorLog1

ErrorLog2

It looks quite good. It seems you are either missing some slices (or there are extra slices of the same region that interfere with the reconstruction). To diagnose the issue, please send us all the image slice positions occurring in your data set by follow these steps:

  • Open DICOM browser
  • Click on the patient
  • Check Advanced checkbox
  • Click `Metadata button
  • Enter Image in the search box
  • Click Copy all files metadata button to copy image position information on the clipboard
  • Paste it to an empty Excel sheet
  • Upload the Excel sheet to OneDrive, Dropbox, or any other file sharing service, and paste the link in your response (taking a screenshot of the sheet and attaching it is not enough, as only a small fraction of the data would be visible)

Hi Andras,

Thank you for your quick reply. Below is the link to the excel file containing image position information. There are two work sheets. One is about CT image, another is about StructSets.

https://polyuit-my.sharepoint.com/:x:/g/personal/tt3yu_polyu_edu_hk/EZb_VmuwjLJGvn4O7GuhNZwBTzYz_IihN-AsWn4DrEiQUQ?e=lPbMsj

Regards,
Tingting

Thank you the table was very useful. It showed that the problem is that you don’t have any slices between coordinates I 66.25 and I 101.25. Slice spacing is 5mm and slices are missing from the end of the list (after 060.DCM), which means that most likely you haven’t received (or did not import into Slicer) files 061.DCM to 067.DCM.

Hi Andras,

Thank you. Thank you for helping me figure out the problem. We did miss some files.

Regards,
Tingting