Problem loading MRI scan. Only one view, axial, is clear, the other two are blurry

Operating system: Windows 10
Slicer version: 4.8.0
Expected behavior: All three views are clear
Actual behavior: Only axial is clear and the other views are a bit titled and blurry. Unable to get a good 3d model out of this data. I’ve attached images for reference.

Screenshot (123)_LIScreenshot (124)

Volumes are often high-resolution only in a certain plane and low-resolution in others to reduce acquisition time (or in case of CT, also to reduce X-ray dose).

You can still use this volume, but for certain operations, such as segmentation, you may want to resample the volume to have uniform resolution along all axes, using Crop volume module, Isotropic spacing option. I would recommend to choose spacing value between the highest and lowest spacing; for example: if you have 0.2 x 0.2 x 5 mm spacing then you may resample it to 1 x 1 x 1 mm.