Problem to select ROI borders of the Crop VOlume module with the mouse

Operating system: Win 10, 64 bits
Slicer version: 4.9.0 2018-01-23

Hi all,

I had no problem before to use the Crop volume Module and its ROI.
But since this morning, after creating a ROI, it is almost impossible to select with the mouse the colored points to expand ROI borders. From the 3D view, I have no problem. But from slice views, even if the ROI and the points to select are visible, I can barely click on the points to move them. Sometimes, especially in the Red Slice View, I can select and move a point but it is random.

I think I may have changed an option on the Slice views from my python script but I cant figure out what or when. The problem appears when I use the Crop Volume in my python script and when I use the initial Crop Volume module in Slicer.

If some of you has any idea …
Thanks,

Are the handle circles just too small to hit them with your mouse?
Does it look different with the latest stable version (4.8.1)?
What does your Python script do? Is the appearance or behavior of the ROI widget different if you don’t run your script? Can you take a screenshot?

The size of the handles circles could be the problem but I don’t think so. They are around the same size in the 3D view and I have no problem to click and drag them. Also, the size hasn’t change and I was perfectly able to select them before.

Slicer version does not seem to be the issue. I first discovered the problem in a 2-months old nightly version. I uninstalled it and try with latest nightly version and latest stable build version (4.8.1) and the problem is still the same.

Here is a screenshot but everything seems normal to me.

In my script, I am calling the crop volume module with vtkMRMLCropVolumeParametersNode.
But when the ROI got wrong, I had not touched this part of the script for weeks, I was working with fiducials…
Moreover, if I remove my module from Slicer, or just after the installation of a new version, the problem to select the ORI is still here.

crop

Thank you for your fast answer and your time,

Have you switched to a different computer? Changed the image resolution?
You can try to reset your application settings by temporarily removing Slicer.ini file (see more information here) and see if it helps.

I changed the resolutions of the screen and tried another screen with different resolution but problem is still here.
And unfortunately, temporarily removing Slicer Settings didn’t hep either.

What is weird, and links my problem with a potential resolution problem, is that if I click a lot on the point of the ROI, I ends to select it. But it can be after 5 or 100 clicks… But again, I am still working on the same computer and with the same resolution as yesterday…

I will be able to switch to a different computer once at home and I will: download the latest stable version of Slicer, try if Crop Volume is working correctly, install my module and check again the Crop Volume.

If, as expected, everything is working well on the second computer, how can I totally supress all setting files when I uninstall Slicer ? I tried to uninstall Slicer 4.8.1 and to delete the NA-MIC folder in User\AppData\Roaming without any success after the re-installation of Slicer but maybe I forgot some config files ?

I have the same problem, using Windows 10 and a brand new installation of Slicer 4.8.1. Did you by chance solve the problem?

It is fixed in recent nightly versions.