Problem when uploading volumes for registration

Operating system:MAC
Slicer version:4.13
Expected behavior:I have uploaded DWI and FLAIR and I should be able to coregister FLAIR on DWI

Actual behavior:The Brainregistration plug in does not recognise the DWI, therefore I can not upload it and can’t coregister the 2 volumes

If the DWI was loaded as a diffusion volume you’ll need to extract a scalar from it. E.g.estimate the tensor and use the baseline image or create a scalar map like FA (you can do these steps with SlicerDMRI).

I tried but DMRI does not open the DWI


Check the Volume type field of the Volume Information tab of the Volumes module. It should be Scalar to work with the registration tools. If not you need to convert it, e.g. with the Vector to Scalar Volume module, depending on the type.

If I open the Image on volume I see it’s a MRMLMulti in the volume type section.
I still can’t do the registration.

That means your DWI was loaded as a MultiVolume and you can either use the MultiVolume modules to extract a frame from it for registration. Or you can convert it to a Sequence and use that newer infrastructure.

I tried to use the multivolume but I keep having thé same problem: i can not use thé dei images for registration


What I mean is that you need to extract a frame as a single scalar volume from the multivolume and then you can use that frame for registration.