General Registration won't recognize a series


I am trying to co-register two different sequences from the same patient in Slicer, however, only one of the sequences is being recognized in the drop down menu for the fixed and moving images. I can select both sequences as volumes in other modules, but the registration does not display one of the sequences. Any hep is much appreciated.

What is the volume type? You can find it in Volumes module. It can be Scalar, Vector, Tensor, etc.

If it is a vector volume then use Vector to Scalar volume module to convert to scalar volume.

On the vector to scalar module it won’t let me click the ‘Input Vector Volume’ drop down. It lets me select an output scale volume but not an input.

What is the volume type of the two volumes? You can find it in Volumes module. It can be Scalar, Vector, Tensor, etc.

It says its an ‘MRMLMulti’ volume

I tried to resample using the ‘Resample scalar/vector/DWI Volume’ module (input: the image, output: a newly created volume, reference volume: another scalar volume), but the output image is only a single slice and not an entire volume.

This means that the image is a time series. Most likely a single slice, changing in time.

Its a T2-weighted structural image – I’m not sure why it would read it as a time series … is there any way to convert it to a scalar volume?

1 Like

Depending on your data it might work to turn off the multivolume plugin and select scalar volume explicitly using the advanced dicom import option.

That worked, thank you very much!