Problematic behavior of the extension manager

Operating system: Mac OS 10.15.4
Slicer version: Slicer-4.11.0-2020-04-01-macosx-amd64
Actual behavior:
Something is broken/bizarre with the extension manager. I need to click twice for the window to appear and the history tab is empty. After I install some extensions, i do not get a prompt to restart. When I close the extension manager and exit slicer, then the extension manager window pops up on its own and prompts for a restart.

1 Like

These issues are certainly annoying. I’ve submitted a bug report on the issue tracker to discuss it there and make sure it is included in the Slicer5 roadmap.

Just want to add that I get the same thing on Windows when I install a new Slicer Nightly. It takes two clicks to open the extension manager, then it loads with nothing in it, then it transiently shows several error messages like: {1e8be032-811c-4583-b51d-7da23cafc52d}: 5: Operation canceled. It shows nothing listed in extensions to restore or manage, and the “install” tab initially shows nothing, then eventually shows the list of categories. Clicking on a category launches another interminable wait. Minutes later, there is something in the list of extensions to restore, although today it is telling me that none of those extensions are usable in the current nightly preview (2020-05-27 on Windows), which means I can’t really use this version and will need to go back to an earlier version.

Is there a way to tell whether a particular extension is supported in a release? I looked at the CDash dashboard, but I couldn’t make sense of it. I regularly use SlicerJupyter, SegmentEditorExtraEffects, and SlicerOpenCV, and the current nightly’s extension manager is telling me that none of these are compatible.

It’s now been about 30min, and this is still what the Extension manager shows:

EDIT: Now it has finally become responsive again, and it has decided that the Extensions I care about ARE compatible and I can install them. This is a frustrating process for users, and the sluggishness and inconsistency of this makes me reluctant to update frequently.

I find this really frustrating, too. This unreliability is very harmful because most likely newcomers immediately give up on the entire software when they encounter this.

@jcfr @Sam_Horvath What is the current state of migrating the extension manager to a new backend? How much work is still needed? What can we do to make it happen?

1 Like

From the post at Running Slicer on headless server (Installing Extensions and more...) it appears resources need to be allocated for it. Whether that is people scheduling or a monetary decision is unknown to me.

Is the extension manager up and running? (6-4-2020)
I get a “Loading extensions” message that won’t go away.
I have tried multiple wifis and the firewall is not blocking Slicer. I have tried multiple computers/windows 4.11.0 Slicer applications.

I am also unable to open the following website…


Sorry, this is a temporary issue that should resolve on its own, please try again in 30-60 minutes.

We are in the process of upgrading the software infrastructure to make the extension server work more reliably.

this behavior doesn’t seem to be resolved?

Even with the latest preview, I still need to click the extension manager to twice to open?

Have you tried to click once and wait (up to several minutes)?

Operating system: macOS Catalina 10.15.5
Slicer version: 4.11.0
Expected behavior: open the extension manager successfully and have access to the catalog of available extensions

Actual behavior:
When I click on the “Extension Manager” icon for the first time after launching Slicer, the following error message is always displayed.

After closing the error window by pressing the “annuler” (= cancel) button and clicking again on the “Extension Manager” icon, I can open the extension manager. The “Manage Extensions” and “Restore Extensions” tabs work fine, but the “Install Extensions” tab always remains blank with no loading symbol whatsoever.

Has this problem been reported by other users?

In the meantime, I was able to install the Surface Wrap Solidify extension manually using the Extension Wizard and the extension GitHub.

Thanks for the help :slight_smile:

Yes, this issue has been reported and you can track the status at I will link your post there to provide additional info. Thank you!

1 Like