Problems with 3D Slicer 5.0.3 Installation on Fedora 36

Hello all! I am running into some issues when trying to run Slicer 5.0.3 on my Fedora 36 workstation.

I followed the instructions given here (Getting Started — 3D Slicer documentation), making sure to install the necessary dependencies and removing the included libcrypto files.

When I try to run the Slicer executable, I get the following error:

Found metadata in lib /usr/img/Slicer503/lib/QtPlugins/platforms/libqxcb.so, metadata=
{
“IID”: “org.qt-project.Qt.QPA.QPlatformIntegrationFactoryInterface.5.3”,
“MetaData”: {
“Keys”: [
“xcb”
]
},
“archreq”: 0,
“className”: “QXcbIntegrationPlugin”,
“debug”: false,
“version”: 331520
}

Got keys from plugin meta data (“xcb”)
QFactoryLoader::QFactoryLoader() checking directory path “/usr/img/Slicer503/bin/platforms” …
Cannot load library /usr/img/Slicer503/lib/QtPlugins/platforms/libqxcb.so: (libxcb-icccm.so.4: cannot open shared object file: No such file or directory)
QLibraryPrivate::loadPlugin failed on “/usr/img/Slicer503/lib/QtPlugins/platforms/libqxcb.so” : “Cannot load library /usr/img/Slicer503/lib/QtPlugins/platforms/libqxcb.so: (libxcb-icccm.so.4: cannot open shared object file: No such file or directory)”
qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb.

error: [/usr/img/Slicer503/bin/SlicerApp-real] exit abnormally - Report the problem.

I tried:
dnf install libxcb-icccm.so.4
I got:
No match for argument: lixcb-icccm.so.4
Error: Unable to find a match: lixcb-icccm.so.4

I tried:
dnf list libxcb
I got:
Installed Packages
libxcb.i686 1.13.1-9.fc36 @fedora
libxcb.x86_64 1.13.1-9.fc36 @fedora

I tried reinstalling libxcb, to no avail.

Any ideas of where to go from here would be greatly appreciated, thank you!