RegistrationQA extension does not work on Linux but work on Windows


Does anyone successfully run the RegistrationQA on Slicer 4.13.0 for Linux?
I tried but the RegistrationQA menu (Registration Quality Assuarance in the Registration module menu) did not appeared.
I built the Slicer4.13.0 for Linux from source on 28 March. I pulled the source from Slicer master branch on on that date. The build was done fine. the built 3D slicer worked fine. Installation of the registrationQA extension was done without problem. Of course, I installed SlicerRT extension because the RegistrationQA required it.

I built the same revision Slicer on Windows11. the built Slicer for Windows works fine and the registrationQA is also work fine. I can see the Registration Quality Adssurance menu in the Registration module menu.

My environment
OS ubuntu20.04
Cmake 3.23.0-rc2
gcc 9

Cmake 3.21.5
compiler Visual studio 2019 (free version)

Could you give me an advice?
Thank you.

The official linux build of RegistrationQA extensions seems to work well on Linux. If you build the extension yourself then you need to add all SlicerRT module folders and RegistrationQA module folders to the additional module paths.


Thank you for your rapid reply.
I built the 3D slicer, but the RegistrationQA and SlicerRT was installed from the extension manager.
Thanks for the information that the RegistrationQA should work on the Slicer for Linux. I will straggle more for it.

It is hard to guarantee ABI compatibility (that your executable can successfully load a dynamic library) if you build them on different computers. You may need to use the exact same versions of runtime libraries, Qt, etc. with the exact same build options.

Therefore, if you build Slicer it is also recommended to build all the extensions that you need.


Thank for the advice.
I have tried to build the RegistrationQA extension several times from source for the revision fo Slicer after building Slicer and SlicerRT. But, I encountered a compile error during the build.

My purpose is to use a modified Plastimach DIR of SlicerRT which I modified the source code to be enable to use the “-demon” option. that work fine. but when I install the RegistrationQA ext. to the same Slicer, I could find it on the module list. I thought that my modification might affect the execution of the registrationQA because the registrationQA denpends upon the SliceRT, so I removed my SlicerRT and reinstalled original SlicerRT ext. and the registrationQA ext via the extension manager. but the registrationQA did not showup in the module list, lathough the original SlilcerRT works well.
I could not have found a cause of this problem, yet. I will check the library versions and/or try to find a way to run the modified SlicerRT and the RegistrationQA properly.

Pull the latest version of SlicerRT and RegistrationQA. They build without problems on the linux factory machine.


OK, I will try and reply a result.