Slicer elatix cannot be installed


(Tom Jainey) #1

Hi

I downloaded the latest nightly version of slicer. I cannot get the sequence registration to work. I ve installed the sequences plug in and 4D elatix.

I am getting an error message saying I need slicer elastix module which cannot be found
Could you pls help

Thanks


(Steve Pieper) #2

What platform (OS) and slicer version are you using? I installed sequence registration yesterday on nightlies of mac and linux and it worked fine.

@jcfr: the dashboards do indicate a lot of extension issues on the factory machines.


(Csaba Pinter) #3

Probably Mac, see

We haven’t had a SlicerElastix on Mac for at least a year. We should at least upload a package for the stable if we cannot fix the factory build.

After a quick search there were unanswered inquiries about the same thing from others, such as

I did my best to investigate then to push the issue, but it’s not resolved as of now.


(Csaba Pinter) #4

Hm we actually do have a SlicerElastix package for today’s nightly:
http://slicer.cdash.org/index.php?project=SlicerPreview&filtercombine=or&filtercount=1&showfilters=1&field1=label&compare1=63&value1=SlicerElastix

But we seem to have a Windows issue now :slight_smile:

Update: this is the last day it worked, 10 days ago.


(Jean Christophe Fillion Robin) #5

the dashboards do indicate a lot of extension issues on the factory machines.

Most of them are compilation errors that could easily be fixed.

Regarding SlicerElastix issues:

cl : Command line error D8021: invalid numeric argument '/Wno-inconsistent-missing-override' [D:\D\P\S-0-E-b\
SlicerElastix-build\elastix-build\CMakeFiles\CMakeTmp\cmTC_381f5.vcxproj] [D:\D\P\S-0-E-b\SlicerElastix-build
\elastix.vcxproj]

          0 Warning(s)
          1 Error(s)

[1] it failed because of server issue. This a known problem and we have path forward, we need resources (aka financial support) to finalize the transition.


(Jean Christophe Fillion Robin) #6

SlicerElastix is available on macOS for both the latest release as well as the nightly build (see above).


(Csaba Pinter) #7

Yes I have seen that since then. It’s great news and good to know.


(Steve Pieper) #8

Thanks for catching that Jc - after the commit I was wondering if I needed to make that flag conditional to be mac-only but I couldn’t get any error message from the dashboard. The windows and linux build messages were cryptic and I thought they were unrelated since so many other things were breaking. I guess this is the server issue you refer to?

In any case I can add a check so that the flag is only added on mac.


(Steve Pieper) #9

I think this will fix it.