Remove CT table from volume rendering

Hello all,

I am attempting to visualize the skeletal elements of a CT scan (DICOM), along with taking screenshots suitable for publication. I am using the volume rendering module CT-AAA2 preset and it looks lovely; however, I can’t figure out how to manually eliminate the CT table from the image to assist with the picture clarity (I am attempting to visualize the sacrum and an unusual growth on the L side, but the table is obscuring the view.) As far as I can tell, I can only selectively crop the ROI A-P, Lateral-Medial, Superior-Inferior, but I can not crop close enough to the specimen without cutting out portions of the bone. I have attempted troubleshooting, but with no success. Any advice would be greatly appreciated - the DICOM viewer that came with the scan is not as clean as the image that 3DSlicer can produce.
Thank you!

Easiest would be to use the Segment editor with the scissors to outline the part you want to keep and then use the mask volume tool to make a new volume to render. Should be just a few clicks.


You may also try the ‘Remove CT table’ module in SlicerSandbox extension that you may install using the Enxtensions manager.

Another option is to use this module that does more or less the same thing. No guarantees, just worth a try. Please read its limitations. Your result is much welcome.

Hey, Steve!

Thank you for your reply. I did think to attempt to make a segment from the scan and simply crop the CT table out with the scissors tool; however, I can’t seem to edit any of the scan with the tools. Here is a look at the screen with the thresholding tool selected; it looks like the editable area is somehow outside of the content of the scan. I have some experiencing segmenting, and I have never come across this problem. Since I don’t need to create a file for 3D printing etc. I thought maybe there was an easier way to selectively “crop” the image in the volume rendering module.

Thank you for your time, I appreciate the guidance!

Try just playing with the scissors and the mask volume tools. You will want to make the fill volume something like -1000 when you subtract the table. To get a general idea of how the segment editor works google for tutorials. If you really think there’s a bug or something special about your data let us know, but I think you just need to try some more things.

1 Like

The full process is explained step-by-step in this video:

However, CT table is usually designed so that radioopaque parts never directly touch the bones and the human body shape is generally a convex shape, so the Remove CT table module should work well in most cases, fully automatically. Have you tried it? Did it work? Have you tried the other module that @chir.set suggested?


Thank you, Steve!

I am convinced the program was being buggy. I tried multiple times to reupload the data, but every time I entered the segment editor I was unable to use any of the tools to create a segment within the tissue contained in the scan - I was only able to edit outside of the tissue contained in the scan. I tried again the next day and I was able to created segments - no problem. Thank you so much!

Screenshot 2023-04-14 092502

Thank you, Andras!

I am convinced the program was being buggy. I simply reloaded my data again from fresh today and it worked fine. One can see the green thresholding highlighting outside of the tissue within my scan in the image I attached to my recent reply to Steve. Today, for whatever reason, it worked fine. I was able to use your recommended video to guide the masking process for my image - Thank you so much!

1 Like

Have you tried the fully automatic table removal? Did it work?

1 Like

It seems @Jonathan_Millard is too busy to reply to helpers. Anyway, his last image shows success by whatever means, so good for him.

I didn’t try the fully automatic table removal, but after several attempts reloading the dataset the segmentation tools started cooperating. Thank you again for your time, your recommendations and linked video were extremely helpful!

1 Like

Sorry, @chir.set - but as you can see, I have replied to helpers and expressed my genuine gratitude. I think the issue was an actual bug in the program, as evidenced by the thresholding tool image in my previous reply. After several attempts to reload my data, it finally worked. Thanks…

@Jonathan_Millard I’m very glad it worked for you in the end.

FYI, we take software bugs very seriously so if you have a way to replicate any issues you experienced please report them so that they can be investigated and fixed. One of the main reasons we engage the community actively is to identify and fix issues so that everyone benefits. Thanks for your help with this effort!

1 Like

@Jonathan_Millard I just asked about the automatic methods repeatedly because I was curious to see if that we developed works well; and to understand if there are some limitations of our tools that would make people not want to use them.

1 Like