Rename Python interactor to Python console?

While implementing some improvements in Slicer’s Python console, I’ve realized that just how odd the Python interactor term is, which we use at a number of places in the Slicer GUI and documentation. Google search indicates that this term is not used anywhere else in the world, just in Slicer.

Would anyone object to renaming Python interactor to Python console in Slicer?


Good idea, imho. Whenever I describe the Python capabilities of Slicer to new users, I also refer to it as a “Python console”.

1 Like

Python Interactor → Python Console is fine with me.

Here was an old comment from me on this topic about a year ago

  • I have thought about changing “Python Interactor” → “Python Console” as the materials most new users see related to Python (not specific to Slicer) is related to using a “Console” or an “Interactive Shell”. To be consistent with the terminology that new users to python might see elsewhere and maybe even just to be consistent with internal terminology such as “ctkPythonConsole” widget, that “Python Console” may be the better name.


1 Like

No objections. It is confusing when someone says to post this code in the Python console but the tool bar has a tab for a Python interactor.

1 Like

I completely agree with renaming it to console. When I mention it to anyone as “interactor” I always feel it needs more explanation. “Console” wouldn’t, it is quite straightforward and unambiguous I think.

1 Like