Renaming Scalar Bar to Color Bar

Could we rename “ScalarBar” to something like “Color Bar” or “Color Scalar Bar” in the GUI? I know the underlying vtk object is called a vtkScalarBarActor with the description:

A scalar bar is a legend that indicates to the viewer the correspondence between color value and data value.

I’m not sure why “Color” was not included in the name of the object.

I have noticed in various forum posts people referring to it as the “Color Bar” while in the GUI it is labeled as “ScalarBar”. This is probably a contributing factor for people struggling to find it in addition to it being buried in DataProbe module which is a separate issue.


It’s also confusing that the controls for the 2D scalar bar are in the DataProbe and the 3D scalar bar is in the Colors module. I think it would be logical to access this kind of setting via right click on the background of the viewer (or maybe in the controller widget, but those are very busy already).

+1 for “Color Scalar Bar” in the GUI

1 Like

I issued to update the name used in the GUI to “Color Scalar Bar”.

1 Like

Yes, it should be shown/hidden at the same place where the displayed volumes are selected. Probably it just happened to be placed in the Data Probe module just because the developer who has implemented it was only comfortable with Python and did not know that it should have been implemented properly using a displayable manager. I think we already have an issue for reworking the Data Probe module.

I don’t see a github issue for that work or transitioning it to use a displayable manager. The closest git issue seems to be which is incorporating some changes from the Paraview scalar bar. You might want to write up a git issue with these specific details about converting to use a displayable manager

I could not find a related issue, so added this: