Resample DTIVolume error!

Operating system: Windows 7 professional
Slicer version: 4.6.2
Expected behavior: Sample data from tutorial should execute registration
Actual behavior: I downloaded the sample data set to perform registration of DTI to MRI from the Slicer page: https://na-mic.org/wiki/Projects:RegistrationLibrary:RegLib_C03

However, I am able to successfully perform only part 1 of this two-step process. The program takes too long to compute resampling of the DTI volume, and then I get an error message as attached with this post. I tried doing the registration on 2 different computers, but the error persisted. How can I resolve this?

Could you try after changing this setting: Edit / Application settings / Modules -> check Prefer Executable CLIs?

Could you please also try with the latest nightly version?

1 Like

I tried both suggestions but they didn’t work. When I used the nightly build, the same error showed up again (image below)

Could you save the scene into a .mrb file right before you click Apply (that would cause the crash), upload it somewhere, and copy the link here?

Sure, or how about I upload the file here directly? Would that work?

File size and type are limited here. Use Dropbox, OneDrive, Google Drive, etc.

Here is the Google drive link: https://drive.google.com/file/d/0B9ZRwZrndb2DR0Q5SF9EQ2YxRDA/view?usp=sharing

I was able to reproduce the issue. The problem is that due to some reason this CLI module uses .mat extension for writing transforms, which is not capable of handling composite transforms. I’ll change it to use .h5, as that can handle any combination of transforms. Tomorrow’s nightly version should work well.

1 Like

Thank you very much! I’ll wait for the new nightly version, in that case.

And as far as the tutorial steps are concerned, instead of selecting “displacement”, I would then have to pick “h5”, is that right?

You don’t have to do anything differently, it’s just an internal change in file format.

Alright, thanks!

Rewati Kulkarni

Research Assistant, Injury Biomechanics Lab.

University of Pennsylvania,
Department of Bioengineering
+1 267-648-7960 | rewati.p.k01@gmail.com rewati.p.k01@gmail.com