Rotation not account with brainfit

Hello Slicer Community,
We have created CT and MRI numerical phantom to test the accuracy of registration software. With very simple form like an ellispsoide and just two value 0 for the background and 700 for the ellipsoide. If we translate them Brainfit succeed to register them with a very good accuracy (less then one voxel) but if there is rotation he do not apply any rotation. We try to increase the number of point or use mask but it didn’t solve the problem. You can access the image with this link.
https://drive.google.com/drive/folders/1WSGeMJ8vlPdEiVRLPBNIiH7ChLy48hPS?usp=sharing!
Do you have any clues?
Thank you,
Cyril Jaudet, PhD
Centre françois Baclesse,
Caen, France

registration_rotation_problem

In general, you need to have a reasonably close initial alignment. In cases like this, automatic alignment methods may work (try all options available in “Initialize Transform Mode”). You could probably also increase the capture range of the registration by tuning optimization parameters (steps sizes, relaxation factor, etc). Finally, you can also try SlicerElastix instead of BRAINS.