Scale issue with Auto3dgm

I’ve run into what I hope is a newbie error–I’m using Auto3dgm to align series of meshes (all ply files of a femur, same species). The alignments look great, but the scale is completely wonky.

For example, when I measure length on the before scan, the ruler tool shows 135mm. When it check it on the aligned scan after running Auto3dgm the length is 0.003337mm.

I’ve checked the Auto3dgm settings and each of the meshes and everything looks right. Tried all the standard things like relaunch/reboot. Is there something obvious I’m missing?

Many thanks for your help/advice!

As I recall Auto3Dgm saves multiple outputs. If you want to preserve the scale and still have your pseudolandmarks on the model, I think the folder you want is OSS (original sample space or something like that).

1 Like


Thanks for helping me troubleshoot this. The landmark files are all there as they should be, but my goal with Auto3dgm was to automate mesh alignments so I can do batch alignments and use the aligned meshes in another program where the scale will be important.

I’m hoping to find a way to either restore the scale on the aligned scans, or to prevent Auto3dgm from adjusting the scale at all if that’s possible.

Below are before-alignment and after-alignment photos of the same mesh.

Thanks and appreciate your help on this!

If your goal is to just align models (but not create pseudoLMs), then I don’t think Auto3Dgm will work for you, as part of its pipeline requires scaling to unit size. You can of course manually scale the aligned models: Do what you just did in the screenshot, divide the numbers to each and scale the small model by that factor (using the transforms module or the surface toolbox).

If you are only looking into alignment, you might find ALPACA more convenient and probably faster. It is not meant as a stand alone alignment tool, so you do need to one dummy pointList to fool into thinking you are transferring points. Choose one of your samples as the sample that everything is going to be aligned against, and enter that as the target model, and set one of the femur that needs to be aligned as the source (also create a dummy markup point), and run through the ALPACA with default settings.

What you want (aligned sample), will be available under the Display Source Model (rigidly registered). In this case the red gorilla skull is the one that was aligned, and the yellow skull was the target.

You do have to run one sample at a time, but it should be relatively quick (1-2 minutes per sample). In future we hope to have a standalong pointcloud based registration of 3D models (so that you don’t fake it in ALPACA), but that’s still in works…

1 Like

Hello again,

Thank you for the explanation on Auto3dgm–that helped me understand the scale transforms. Somewhere in the cobwebs of my mind I remember playing with ALPACA, so I’ll revisit that.

Many thanks for your time!