Scissor bug in 4.6.2 release


I’m working with 3D Slicer and i want to cut some part of my 3D Volume. We can do this using Segment Editor and Scissor like in the video :

But on my pc, it doesn’t work.

An idea ?


Please use the nightly download.

I did, but nothing change.

Can you send us a screen capture of what you tried to do? Or describe in detail, what button you clicked, where you drew contours, what you expected to happen, and what happened instead?

I try to erase a part of my Volume like in this example.

Your screenshot is not from a recent nightly. Please download and install the nightly (yellow buttons on the bottom) from here:

I tried with the nightly version, it doesn’t work too

In the video that you linked, the bones were not volume rendered, but they were segmented structures.

Scissors erase from segmentations. If you want to erase from your input volume then install SegmentEditorExtraEffects extension and use the “Mask volume” effect, as shown here:

Hi !

Thansk you, i understand the fact that i have to create a 3D segment before Scissor it. It works perfectly.
I used a threshold to create the segment and use scissor to cut parts i don’t want.

Tks, Bye !

1 Like