Scissors Not Working

I am in the segment editor, and I am attempting to remove jewelry and bone from my image. I have selected the erase inside option. Nothing happens once I’ve circled the areas with the scissors that I want to remove. Please help.

Hello, Sandra.
Sorry to hear that it didn’t work.
From my experience what commonly happens is that the segment you were tying to erase wasn’t selected in the panel on the side.
See below.
image
In the example, only Segment_2 is visible; Segment_3 and Segment_4 are hidden. So the user will often expect to be editing Segment_2*. (Alternatively, the other segments might be visible, but located outside of the current field of view**, say.) But none of that matters. the only thing that matters is that Segment_3 is highlighted, so the Scissors effect will be applied to it. Nothing in Segment_2 will be erased.

—DIV

*There’s actually a warning that is displayed in this situation in recent versions of 3D Slicer.
**No warning about this, AFAIK.

1 Like

This still did NOT work for me. Getting this tool to work is critical for me at the moment as I am working on my dissertation project and am on a strict timeline. Is there anyone willing to virtually meet with me to help figure this out? One thing I did notice in your example is that underneath the flag you have a pencil icon marking the segment you plan to edit and circles for the others. I do not have a pencil icon. I only have a flag and a check mark icon. Could this be another clue to what is causing this issue? I am available any time in the mornings before noon. Please help. Id be so grateful.
Sandy

Without screenshots of what you have done so far, it is not possible for us to guide you. Please provide a screen capture of what is not working at the stage you are using the scissor tool.

1 Like

Understood. Currently at work but will do tomorrow morning. Thank you!!

OK, SO I have set up the image I want to edit.

My GOAL is to remove everything from this image because all I need to see is the skull. I want to delete the earrings, nose ring, vertebrae, etc… So, I open up the Segment Editor to use the scissors tool…

I use the scissors as directed and absolutely NOTHING happens. Please Help. :frowning:

It looks like you are viewing the volume rendering of the data. Scissors works on the segmentation, not the volume data. You need to create a segment from the volume data, and then cut it with the scissors.

1 Like

Thank you for your response. Can you explain how to create a segment from the volume data?

Image segmentation is a vast subject area. If this is a medical CT scan and you’re concentrating on bones, you can probably use the thresholding tool and pick the right Houndsfield unit range for bones (I’m an entomologist, so I’ve no idea what that would be). You can also use the paint tool, or local thresholding tool, etc. There are a LOT of tools for image segmentation.

Please review these tutorials. You will find them helpful:
https://slicer.readthedocs.io/en/latest/user_guide/image_segmentation.html

Step 1.
Go to Segmentation Editor.

Select Threshold and adjust the sliders so that the bones are green.

This usually means adjusting the first slider up the scale (from a negative value to a positive value) to exclude soft tissue structures.

Once you are happy select Apply. You have now segmented the data set. Click on the “Show 3D” button to see the model.

Step 2.
Now you can use the Scissors on the 3D model to remove sections.