Segmentation issue - "invisible" labels

Hi all,

sorry for semi-reposting (I initially thought this was a pyradiomics issue and therefore posted there, but now figured that it is a segmentation issue):

I am having a problem with importing CNN generated segmentations of two brain structures (bilaterally, so 4 segmentations / VOIs in total) on MRI.

When I load the MRI volume and the segmentation file, it looks good, only the light blue VOI isn’t fully recognized as a segmentation/label it seems:

But when I add it in the Segmentations module it looks fine:

However, out of the four segmentations, I can only edit a single one (the brown one, seg 4), although all four are visible - any segmentation tool that I try on the other three will result in nothing - as if they were not there at all.

How can that be?

The volume and segmentation file are in the folder below (all deidentified of course):


Many thanks!

You can try upgrading to the current Slicer version (5.6.1) and make sure you save the segmentation into an image with integer type (unsigned char, short, etc).

Thanks - I tried the new version, but no change, still not editable.

In terms of saving, what option would that be (i.e. file extension)?

To fix the loading issue, you can convert your numpy array to uint8 before writing to file. Like this: