Only one of 28 segments is showing in 3d

I downloaded a dataset with maps of arterial regions in the brain. It usually works very well to load them as segments and that step worked well. However, when i try and show it in 3D only once of the segments show. I have checked everything I can think of and i can not see any difference between the segmentations in any setting.

Operating system: win 11
Slicer version: 5.2.2 and slicer 4.11
Expected behavior: All segments should show
Actual behavior: only one show

Check in Data module, maybe you have multiple segmentations and only one is shown in 3D. You can adjust visibility and opacity of each segment separately in Segmentations module, maybe something is set there.

If you cannot figure it out then please save the scene as .mrb and share it with us (upload it to dropbox/onedrive/google drive and post the link here) and we’ll have a look.

Hi Andras.
I checked the data modul and all segments look the same and should be visible.

here is the file as a .mrb

Thank you for the help

Thank you for sharing the file. The problem is that the file stores voxels as floating-point value (float type) instead of an integer type. Using floating-point values uses 4-8x more memory than necessary and there can be issues when computing equality between values, therefore Slicer never does this. However, it seems that Slicer does not prevent importing of images of this type as segmentation.

We’ll probably just disable loading of float volumes as segmentations into Slicer (see Segmentation closed surface representation generation fails for float voxels · Issue #6941 · Slicer/Slicer · GitHub).

To fix your problem, you need to set the voxel type to unsigned char (if you have more than 255 segments then unsigned short) when you create a segmentation file. How did you create this .seg.nrrd file?

Hi i downloaded this dataset
and then loaded the atlas file as a segmentation.

Tried with a different version and then it worked.

Thank you for the help!