Segmentation not working with 2 sets of DICOM images

Operating system: Mac Big Sur
Slicer version: 4.11.20210226


I have little experience with 3D Slicer. I managed simple work with one set of DICOM.
When I worked with two sets of DICOMs (CT & MRI).
After I imported the second DICOM, segmentation only worked on the first set (CT or MRI, only can work on the first set).
After linear transformation +/- rigid (6DOF) registration, segmentation did not work on either set (e.g. could not paint, already checked editable intensity range is off, could not adjust threshold limit).
I had changed the order of import, the result was the same.
I must missed some steps.
Please advise on the reason and how to fix it.


See instructions for resolving this here.

I would recommend to upgrade to the current Slicer version. The one that you are using is more than 2 years old, therefore missing hundreds of important fixes and improvements.

Thanks for your advice. Will update and see how it is going.

I Updated the software, but the condition is the same.
I loaded CT, then MRI, and can only work with Segment Editor with CT images, not the MRI one.

This is the data screenshot:

How can I do segmentation also on the second set of DICOM?
Please advise.

Thanks for the advice.
I updated the software.
It is the same.
But after some more work, I found that segmentation only works in the 1st set DICOM area, so I need to transform and register the 2nd set DICOM to the 1st set, then it will work. This solved my problem.

In each imaging study, the patient coordinate system origin is chosen differently and the patient is positioned on the table slightly differently. Therefore, if you want to use multiple images (e.g., CT and MRI) for creating a single segmentation then you need to align them first. You can use the spatial registration methods described here.