Segmentation visible only in 3D

Operating system: Windows 10
Slicer version:4.10.1 (tried also with 4.10.0)
Expected behavior: see segmentation in 2D
Actual behavior: can see only in 3D!

image

Hi

please help me. Unfortunately, the software does not show the painted segment on the 2D screen, just on the 3D. Do you know how can I fix this? It is crucial to me to see them since I need to make a high-resolution segmentation of the hand. Thanks

image

Segmentation can be hidden at 6 places in Segmentations module - check all of them!

  • overall hidden
  • overall hidden slice view
  • overall fully transparent slice view
  • overall not shown in a view
  • segment-specific hidden slice view
  • segment-specific fully transparent slice view

Click on the image below to see all these controls highlighted:

image

Dear Andras,

Unfortunately I have this weird situation

image

Thanks so much for your help!

Could you please choose a segment to see if visibility is not turned off for specific segments?
Could you also show a screenshot that shows the slices in the 3D view (to make sure they overlap)?

Sure!

image

image

I hope they are ok.

How did you create the segmentation? Maybe the segmentation only contain closed surface representation. If that’s the case, either change “Representation in 2D views” to “Closed surface” (or create a binary labelmap representation by clicking on “Create” button in “Binary labelmap” row in Representations section).

I just clicked the “add segment button” in the segment editor… after a while it did not shown up the segmentation in 2D… I did not do anything…

I tried but apparently it does not work

image

image

an interesting thing (maybe) is that if I load the saved data from on a new project (where the" 2d edit view" is functioning) i can t change the position of the slice. It is fixed at the left as in the picture

You need to load a volume to be able to position slice viewers with the slider at the top (you can still position slice views by Shift+MouseMove in the 3D viewer).

How did you create the segmentation?
What would you like to do (edit the segmentation, compute statistics, …)?

From the Segment Editor I just click on the Add button… after nearly 12 bones, the segmentation in 2D disappeared.

If I open a new model, it works perfectly.

I need the model to calculate the electromagnetic distributions of currents in the hand. I need to make a precise hand segmentation in order to have reliable values.

I am new to this software. I find it awesome, but this is bad, because after 6 hours of work probably now I can’t see another solution if not start from scratch

We need to be able to reproduce the problem that you are experiencing to be able to help. Could you record a screen capture video and share that (or give step-by-step description of what you do exactly)?

Dear Andras, I uploaded here the way I did. Basically, I just added segments, used the threshold, painted the segment (sometimes I used fill between the slices) and in the end of the process I used the smoothing tools (one time for each segment, so for each bone).

I am wondering if there’s an upper limit to the number of segments one can make.

PS my project is a master thesis
PPS I m going to delete that video on youtube as soon as this is solved

ok, I was able to fix the problem just by taking the old segments in a new segmentation!
Since a friend of mine had the same problem, I decided to post the solution

Go to data and drag and drop the segments in a new segmentation (I started from scratch a new segmentation, then did that and it worked)
image

If you understand why (sorry I m new to Slicer) maybe you could explain to me, truly thanks for your time!

I don’t see any issue in the video above (segments are still visible in the slice views).

Note that you can probably segment the image probably 10x faster if after settings threshold range form masking, you paint a small piece in each bone then use Grow from seeds effect to create a complete segmentation.

Yes, in the youtube video I just show how I did as you asked me. After few hours of work like that the segments in the 2D screens disappeared.

Yes I know the grow from seed effect, but unfortunately to make a precise work it’s difficult unfortunately (segmentation of all blood vessels, tendons, fat and so on) from a 1T MRI (too low resolution I guess)… I tried but I always have overlapping and weird boundaries

Thanks for the clarification.

If you send one of the scenes file where the segments are not visible in 2D then I would investigate why it could happen.

Hi!

I have the exact same problem:

Operating System: Ubuntu 20.04.2 LTS
Slicer version: 4.11.20210226
Expected behavior: see segmentation in 2D
Actual behavior: can only see segmentation in 3D (even after checking all 6 locations in the Segmentations module)

Context: The segmentation has been generated by a deep neural network. Its dimensions match the dimensions of the CT scans.

@lassoan I can send you the files if you have time to look at it.

Thank you so much for your help :slight_smile: !

Yes, please save the scene as .mrb file, upload it somewhere, post the link here, and I’ll have a look.

Here’s the link of the scene saved as an .mrb file.
I appreciate your help !

You don’t see the segments in slice views, because slice views bounds are set to the background volume by default, and the volume is very far from the segmentation:

You can force your slice viewers to show the segmentation by choosing “Jump slices - centered” crosshair mode and moving the mouse over to the segmentation in 3D view while holding down Shift key.

This issue happens because the geometry if the segmentation is incorrect: the segments have (0,0,0) origin and (1,1,1) spacing. It may also cause problems elsewhere that its scalar type is float. How did you create this segmentation?

1 Like